package libdrm
This commit is contained in:
parent
aea6021c41
commit
303febb30b
2 changed files with 170 additions and 0 deletions
69
libs/libdrm/Makefile
Normal file
69
libs/libdrm/Makefile
Normal file
|
@ -0,0 +1,69 @@
|
|||
# Copyright (C) 2007-2016 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libdrm
|
||||
PKG_VERSION:=2.4.70
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_URL:=http://dri.freedesktop.org/libdrm
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_MD5SUM:=920957cfe25a80efb02be9bd90bf3c1e
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libdrm
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
DEPENDS:=
|
||||
TITLE:=libdrm
|
||||
URL:=http://dri.freedesktop.org/
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--disable-udev \
|
||||
--enable-kms \
|
||||
--disable-intel \
|
||||
--disable-radeon \
|
||||
--disable-amdgpu \
|
||||
--disable-nouveau \
|
||||
--disable-vmwgfx \
|
||||
--disable-omap-experimental-api \
|
||||
--disable-exynos-experimental-api \
|
||||
--disable-freedreno \
|
||||
--disable-freedreno-kgsl \
|
||||
--disable-tegra-experimental-api \
|
||||
--disable-vc4 \
|
||||
--disable-cairo-tests \
|
||||
--disable-manpages \
|
||||
--disable-valgrind
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) \
|
||||
$(1)/usr/include \
|
||||
$(1)/usr/lib
|
||||
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/include/* \
|
||||
$(1)/usr/include/
|
||||
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/{pkgconfig,*.so*} \
|
||||
$(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Package/libdrm/install
|
||||
$(INSTALL_DIR) \
|
||||
$(1)/usr/lib
|
||||
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/*.so* \
|
||||
$(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libdrm))
|
101
libs/libdrm/patches/000-remove-dep-on-pthread-stubs.patch
Normal file
101
libs/libdrm/patches/000-remove-dep-on-pthread-stubs.patch
Normal file
|
@ -0,0 +1,101 @@
|
|||
--- a/configure 2016-07-23 15:19:06.000000000 +0200
|
||||
+++ b/configure 2016-08-27 01:11:02.440530337 +0200
|
||||
@@ -13334,98 +13334,6 @@
|
||||
fi
|
||||
fi
|
||||
|
||||
-pkg_failed=no
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for PTHREADSTUBS" >&5
|
||||
-$as_echo_n "checking for PTHREADSTUBS... " >&6; }
|
||||
-
|
||||
-if test -n "$PTHREADSTUBS_CFLAGS"; then
|
||||
- pkg_cv_PTHREADSTUBS_CFLAGS="$PTHREADSTUBS_CFLAGS"
|
||||
- elif test -n "$PKG_CONFIG"; then
|
||||
- if test -n "$PKG_CONFIG" && \
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"pthread-stubs\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "pthread-stubs") 2>&5
|
||||
- ac_status=$?
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
- test $ac_status = 0; }; then
|
||||
- pkg_cv_PTHREADSTUBS_CFLAGS=`$PKG_CONFIG --cflags "pthread-stubs" 2>/dev/null`
|
||||
- test "x$?" != "x0" && pkg_failed=yes
|
||||
-else
|
||||
- pkg_failed=yes
|
||||
-fi
|
||||
- else
|
||||
- pkg_failed=untried
|
||||
-fi
|
||||
-if test -n "$PTHREADSTUBS_LIBS"; then
|
||||
- pkg_cv_PTHREADSTUBS_LIBS="$PTHREADSTUBS_LIBS"
|
||||
- elif test -n "$PKG_CONFIG"; then
|
||||
- if test -n "$PKG_CONFIG" && \
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"pthread-stubs\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "pthread-stubs") 2>&5
|
||||
- ac_status=$?
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
- test $ac_status = 0; }; then
|
||||
- pkg_cv_PTHREADSTUBS_LIBS=`$PKG_CONFIG --libs "pthread-stubs" 2>/dev/null`
|
||||
- test "x$?" != "x0" && pkg_failed=yes
|
||||
-else
|
||||
- pkg_failed=yes
|
||||
-fi
|
||||
- else
|
||||
- pkg_failed=untried
|
||||
-fi
|
||||
-
|
||||
-
|
||||
-
|
||||
-if test $pkg_failed = yes; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
-
|
||||
-if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
|
||||
- _pkg_short_errors_supported=yes
|
||||
-else
|
||||
- _pkg_short_errors_supported=no
|
||||
-fi
|
||||
- if test $_pkg_short_errors_supported = yes; then
|
||||
- PTHREADSTUBS_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "pthread-stubs" 2>&1`
|
||||
- else
|
||||
- PTHREADSTUBS_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "pthread-stubs" 2>&1`
|
||||
- fi
|
||||
- # Put the nasty error message in config.log where it belongs
|
||||
- echo "$PTHREADSTUBS_PKG_ERRORS" >&5
|
||||
-
|
||||
- as_fn_error $? "Package requirements (pthread-stubs) were not met:
|
||||
-
|
||||
-$PTHREADSTUBS_PKG_ERRORS
|
||||
-
|
||||
-Consider adjusting the PKG_CONFIG_PATH environment variable if you
|
||||
-installed software in a non-standard prefix.
|
||||
-
|
||||
-Alternatively, you may set the environment variables PTHREADSTUBS_CFLAGS
|
||||
-and PTHREADSTUBS_LIBS to avoid the need to call pkg-config.
|
||||
-See the pkg-config man page for more details." "$LINENO" 5
|
||||
-elif test $pkg_failed = untried; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
|
||||
-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
-as_fn_error $? "The pkg-config script could not be found or is too old. Make sure it
|
||||
-is in your PATH or set the PKG_CONFIG environment variable to the full
|
||||
-path to pkg-config.
|
||||
-
|
||||
-Alternatively, you may set the environment variables PTHREADSTUBS_CFLAGS
|
||||
-and PTHREADSTUBS_LIBS to avoid the need to call pkg-config.
|
||||
-See the pkg-config man page for more details.
|
||||
-
|
||||
-To get pkg-config, see <http://pkg-config.freedesktop.org/>.
|
||||
-See \`config.log' for more details" "$LINENO" 5; }
|
||||
-else
|
||||
- PTHREADSTUBS_CFLAGS=$pkg_cv_PTHREADSTUBS_CFLAGS
|
||||
- PTHREADSTUBS_LIBS=$pkg_cv_PTHREADSTUBS_LIBS
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||
-$as_echo "yes" >&6; }
|
||||
-
|
||||
-fi
|
||||
-
|
||||
-
|
||||
|
||||
pkgconfigdir=${libdir}/pkgconfig
|
||||
|
Loading…
Reference in a new issue