seafile-server: bump to 6.3.0
Added patch to remove openssl 1.1 deprecated API. Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
This commit is contained in:
parent
21568764a4
commit
302454f527
4 changed files with 55 additions and 25 deletions
|
@ -8,16 +8,16 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=seafile-server
|
||||
PKG_VERSION:=6.2.2
|
||||
PKG_VERSION:=6.3.0
|
||||
PKG_RELEASE=$(PKG_SOURCE_VERSION)-1
|
||||
PKG_LICENSE:=GPL-3.0
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/haiwen/seafile-server.git
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=6978d2cb2e05cc774370b4d06c9f0a864df71936
|
||||
PKG_SOURCE_VERSION:=a8c66e1bc6f6245e48917f39a24167d22a95dbd6
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
||||
PKG_MIRROR_HASH:=99aa9c41641d7c0ffe18bbab75418b1347dd9e156124472bbee5a6dda09a8057
|
||||
PKG_MIRROR_HASH:=d63667f8cddcac645fb0d350c71e2a32d0c44f47df46a3a013d2dbecb3574d9a
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
|
||||
|
@ -34,7 +34,7 @@ define Package/seafile-server
|
|||
DEPENDS:=+libarchive +libopenssl +glib2 +libsearpc +seafile-ccnet +seafile-seahub +sqlite3-cli +python-mysql +python-urllib3 \
|
||||
+jansson +libevent2 +libevent2-openssl +zlib +libzdb +libsqlite3 +libmysqlclient \
|
||||
+libpthread +libuuid +bash +procps-ng +procps-ng-pkill +SEAFILE_FUSE_SUPPORT:libfuse $(ICONV_DEPENDS)
|
||||
EXTRA_DEPENDS:=seafile-ccnet (=6.2.2-6b9d7e2920aa9b807f9efe9038439b57ce949ecc-1), seafile-seahub (=6.2.2-120e7a299e77968f1af48ea2dcf4bd9b909c426f-1)
|
||||
EXTRA_DEPENDS:=seafile-ccnet (=6.3.0-614926b161623b267b4fb77fa1861718da406103-1), seafile-seahub (=6.3.0-d1ab146a936a6ea1e1581bf3f194e86742f0d3cd-1)
|
||||
MENU:=1
|
||||
endef
|
||||
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
diff -rupN seafile-server-5.1.1.orig/scripts/seaf-fsck.sh seafile-server-5.1.1/scripts/seaf-fsck.sh
|
||||
--- seafile-server-5.1.1.orig/scripts/seaf-fsck.sh 2016-04-21 11:05:26.000000000 +0200
|
||||
+++ seafile-server-5.1.1/scripts/seaf-fsck.sh 2016-04-22 09:10:13.075581325 +0200
|
||||
--- a/scripts/seaf-fsck.sh
|
||||
+++ b/scripts/seaf-fsck.sh
|
||||
@@ -7,7 +7,7 @@ INSTALLPATH=$(dirname "${SCRIPT}")
|
||||
TOPDIR=$(dirname "${INSTALLPATH}")
|
||||
default_ccnet_conf_dir=${TOPDIR}/ccnet
|
||||
|
@ -10,9 +9,8 @@ diff -rupN seafile-server-5.1.1.orig/scripts/seaf-fsck.sh seafile-server-5.1.1/s
|
|||
|
||||
export PATH=${INSTALLPATH}/seafile/bin:$PATH
|
||||
export SEAFILE_LD_LIBRARY_PATH=${INSTALLPATH}/seafile/lib/:${INSTALLPATH}/seafile/lib64:${LD_LIBRARY_PATH}
|
||||
diff -rupN seafile-server-5.1.1.orig/scripts/seaf-gc.sh seafile-server-5.1.1/scripts/seaf-gc.sh
|
||||
--- seafile-server-5.1.1.orig/scripts/seaf-gc.sh 2016-04-21 11:05:26.000000000 +0200
|
||||
+++ seafile-server-5.1.1/scripts/seaf-gc.sh 2016-04-22 09:10:27.211581999 +0200
|
||||
--- a/scripts/seaf-gc.sh
|
||||
+++ b/scripts/seaf-gc.sh
|
||||
@@ -7,7 +7,7 @@ INSTALLPATH=$(dirname "${SCRIPT}")
|
||||
TOPDIR=$(dirname "${INSTALLPATH}")
|
||||
default_ccnet_conf_dir=${TOPDIR}/ccnet
|
||||
|
@ -22,9 +20,8 @@ diff -rupN seafile-server-5.1.1.orig/scripts/seaf-gc.sh seafile-server-5.1.1/scr
|
|||
seaf_gc_opts=""
|
||||
|
||||
export PATH=${INSTALLPATH}/seafile/bin:$PATH
|
||||
diff -rupN seafile-server-5.1.1.orig/scripts/setup-seafile-mysql.sh seafile-server-5.1.1/scripts/setup-seafile-mysql.sh
|
||||
--- seafile-server-5.1.1.orig/scripts/setup-seafile-mysql.sh 2016-04-21 11:05:26.000000000 +0200
|
||||
+++ seafile-server-5.1.1/scripts/setup-seafile-mysql.sh 2016-04-22 09:11:50.083585953 +0200
|
||||
--- a/scripts/setup-seafile-mysql.sh
|
||||
+++ b/scripts/setup-seafile-mysql.sh
|
||||
@@ -40,15 +40,10 @@ function check_python_executable() {
|
||||
function check_python_module () {
|
||||
module=$1
|
||||
|
@ -65,10 +62,9 @@ diff -rupN seafile-server-5.1.1.orig/scripts/setup-seafile-mysql.sh seafile-serv
|
|||
export PYTHON=$PYTHON
|
||||
+export PYTHONPATH="/usr/share/seafile/seafile-server/seahub/thirdpart:$PYTHONPATH"
|
||||
|
||||
exec $PYTHON "$python_script"
|
||||
diff -rupN seafile-server-5.1.1.orig/scripts/sqlite2mysql.sh seafile-server-5.1.1/scripts/sqlite2mysql.sh
|
||||
--- seafile-server-5.1.1.orig/scripts/sqlite2mysql.sh 2016-04-21 11:05:26.000000000 +0200
|
||||
+++ seafile-server-5.1.1/scripts/sqlite2mysql.sh 2016-04-22 09:02:22.047558854 +0200
|
||||
exec $PYTHON "$python_script" "$@"
|
||||
--- a/scripts/sqlite2mysql.sh
|
||||
+++ b/scripts/sqlite2mysql.sh
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/bin/sh
|
||||
+#!/bin/bash
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
diff -rupN seafile-server-5.1.1.orig/lib/repo.vala seafile-server-5.1.1/lib/repo.vala
|
||||
--- seafile-server-5.1.1.orig/lib/repo.vala 2016-04-19 15:44:32.000000000 +0200
|
||||
+++ seafile-server-5.1.1/lib/repo.vala 2016-04-25 21:29:33.327962235 +0200
|
||||
@@ -30,7 +30,7 @@ public class Repo : Object {
|
||||
--- a/lib/repo.vala
|
||||
+++ b/lib/repo.vala
|
||||
@@ -34,7 +34,7 @@ public class Repo : Object {
|
||||
// data format version
|
||||
public int version { get; set; }
|
||||
|
||||
|
@ -9,8 +8,8 @@ diff -rupN seafile-server-5.1.1.orig/lib/repo.vala seafile-server-5.1.1/lib/repo
|
|||
+ public int64 last_modify { get; set; }
|
||||
public int64 size { get; set; }
|
||||
public int64 file_count { get; set; }
|
||||
public string head_cmmt_id { get; set; }
|
||||
@@ -40,7 +40,7 @@ public class Repo : Object {
|
||||
public string last_modifier { get; set; }
|
||||
@@ -45,7 +45,7 @@ public class Repo : Object {
|
||||
public string repo_id { get; set; }
|
||||
public string repo_name { get; set; }
|
||||
public string repo_desc { get; set; }
|
||||
|
@ -19,7 +18,7 @@ diff -rupN seafile-server-5.1.1.orig/lib/repo.vala seafile-server-5.1.1/lib/repo
|
|||
|
||||
// Section 2: Encryption related
|
||||
// Members in this section should be set for every Repo object
|
||||
@@ -63,7 +63,7 @@ public class Repo : Object {
|
||||
@@ -68,7 +68,7 @@ public class Repo : Object {
|
||||
get { return _relay_id; }
|
||||
set { _relay_id = value; }
|
||||
}
|
||||
|
@ -28,7 +27,7 @@ diff -rupN seafile-server-5.1.1.orig/lib/repo.vala seafile-server-5.1.1/lib/repo
|
|||
public bool auto_sync { get; set; }
|
||||
public bool worktree_invalid { get; set; }
|
||||
|
||||
@@ -155,7 +155,7 @@ public class DeletedEntry : Object {
|
||||
@@ -162,7 +162,7 @@ public class DeletedEntry : Object {
|
||||
public string obj_name { get; set; }
|
||||
public string basedir { get; set; }
|
||||
public int mode { get; set; }
|
||||
|
|
|
@ -0,0 +1,35 @@
|
|||
From 13f95a28ce12216ba51cf0ca8d61c3d89689d02b Mon Sep 17 00:00:00 2001
|
||||
From: Eneas U de Queiroz <cote2004-github@yahoo.com>
|
||||
Date: Wed, 6 Jun 2018 18:11:47 -0300
|
||||
Subject: [PATCH] Remove API deprecated in openssl 1.1
|
||||
|
||||
Openssl 1.1 has deprecated RAND_pseudo_bytes. It won't compile with
|
||||
openssl built witout deprecated API.
|
||||
|
||||
Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
|
||||
---
|
||||
common/seafile-crypt.c | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/common/seafile-crypt.c b/common/seafile-crypt.c
|
||||
index c7d1702..c3cebf5 100644
|
||||
--- a/common/seafile-crypt.c
|
||||
+++ b/common/seafile-crypt.c
|
||||
@@ -81,9 +81,14 @@ seafile_generate_random_key (const char *passwd, char *random_key)
|
||||
|
||||
int rc = RAND_bytes (secret_key, sizeof(secret_key));
|
||||
if (rc != 1) {
|
||||
+#if OPENSSL_VERSION_NUMBER < 0x10100000L || OPENSSL_API_COMPAT < 0x10100000L
|
||||
seaf_warning ("Failed to generate secret key for repo encryption "
|
||||
"with RAND_bytes(), use RAND_pseudo_bytes().\n");
|
||||
RAND_pseudo_bytes (secret_key, sizeof(secret_key));
|
||||
+#else
|
||||
+ seaf_warning ("Failed to generate secret key for repo encryption "
|
||||
+ "with RAND_bytes().\n");
|
||||
+#endif
|
||||
}
|
||||
|
||||
seafile_derive_key (passwd, strlen(passwd), 2, key, iv);
|
||||
--
|
||||
2.16.4
|
||||
|
Loading…
Reference in a new issue