Merge pull request #13071 from neheb/quot

quota: fix compilation without sys/cdefs
This commit is contained in:
Rosen Penev 2020-08-10 19:29:01 -07:00 committed by GitHub
commit 301f3a4d0e
No known key found for this signature in database
GPG key ID: 4AEE18F83AFDEB23
2 changed files with 19 additions and 1 deletions

View file

@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=quota PKG_NAME:=quota
PKG_VERSION:=4.05 PKG_VERSION:=4.05
PKG_RELEASE:=2 PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/linuxquota PKG_SOURCE_URL:=@SF/linuxquota

View file

@ -0,0 +1,18 @@
--- a/quota.h
+++ b/quota.h
@@ -1,7 +1,6 @@
#ifndef GUARD_QUOTA_H
#define GUARD_QUOTA_H
-#include <sys/cdefs.h>
#include <sys/types.h>
#include <stdint.h>
@@ -182,6 +181,6 @@ enum {
#endif
#endif
-long quotactl __P((int, const char *, qid_t, caddr_t));
+long quotactl (int, const char *, qid_t, caddr_t);
#endif /* _QUOTA_ */