gnutls: updated to 3.4.0
Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
This commit is contained in:
parent
82ce4b745c
commit
3018b32bbe
3 changed files with 90 additions and 22 deletions
|
@ -8,13 +8,14 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gnutls
|
||||
PKG_VERSION:=3.3.14
|
||||
PKG_VERSION:=3.4.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_USE_MIPS16:=0
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=ftp://ftp.gnutls.org/gcrypt/gnutls/v3.3
|
||||
PKG_MD5SUM:=7f4465f8c564cf9cb8f5cb38b909f7ca
|
||||
PKG_SOURCE_URL:=ftp://ftp.gnutls.org/gcrypt/gnutls/v3.4
|
||||
PKG_MD5SUM:=aa015c2666b031044edfb01b01980d84
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_MAINTAINER:=Nikos Mavrogiannopoulos <nmav@gnutls.org>
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
@ -104,6 +105,7 @@ define Package/libgnutls-openssl
|
|||
$(call Package/gnutls/Default)
|
||||
TITLE+= (OpenSSL compat library)
|
||||
DEPENDS+= +libgnutls
|
||||
CONFIGURE_ARGS+= --enable-openssl-compatibility
|
||||
endef
|
||||
|
||||
define Package/libgnutls-openssl/description
|
||||
|
@ -122,7 +124,6 @@ CONFIGURE_ARGS+= \
|
|||
--enable-local-libopts \
|
||||
--disable-doc \
|
||||
--disable-tests \
|
||||
--disable-rsa-export \
|
||||
--with-default-trust-store-dir=/etc/ssl/certs/ \
|
||||
--disable-crywrap \
|
||||
--with-librt-prefix="$(STAGING_DIR)/"
|
||||
|
@ -182,14 +183,12 @@ define Build/InstallDev
|
|||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/include/gnutls \
|
||||
$(1)/usr/include/
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/libgnutls{,-openssl}.{a,so*} \
|
||||
$(1)/usr/lib/
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/gnutls.pc \
|
||||
$(1)/usr/lib/pkgconfig/
|
||||
endef
|
||||
|
||||
|
||||
define Package/certtool/conffiles
|
||||
/etc/gnutls/certtool.cfg
|
||||
endef
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
diff --git a/src/socket.c b/src/socket.c
|
||||
index 82c6252..e2feda9 100644
|
||||
--- a/src/socket.c
|
||||
+++ b/src/socket.c
|
||||
@@ -241,10 +241,6 @@ socket_open(socket_st * hd, const char *hostname, const char *service,
|
||||
/* get server name */
|
||||
memset(&hints, 0, sizeof(hints));
|
||||
|
||||
-#ifdef AI_IDN
|
||||
- hints.ai_flags = AI_IDN|AI_IDN_ALLOW_UNASSIGNED;
|
||||
-#endif
|
||||
-
|
||||
hints.ai_socktype = udp ? SOCK_DGRAM : SOCK_STREAM;
|
||||
if ((err = getaddrinfo(hostname, service, &hints, &res))) {
|
||||
fprintf(stderr, "Cannot resolve %s:%s: %s\n", hostname,
|
84
libs/gnutls/patches/001-libopts-detection.patch
Normal file
84
libs/gnutls/patches/001-libopts-detection.patch
Normal file
|
@ -0,0 +1,84 @@
|
|||
diff --git a/configure.ac b/configure.ac
|
||||
index 7c454cd..185ebb6 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -64,7 +64,7 @@ if test "$enable_tools" != "no" || test "$enable_doc" != "no"; then
|
||||
***
|
||||
*** autogen not found. Will not link against libopts.
|
||||
*** ]])
|
||||
- enable_local_libopts=yes
|
||||
+ included_libopts=yes
|
||||
fi
|
||||
fi
|
||||
|
||||
@@ -523,7 +523,7 @@ fi
|
||||
|
||||
AM_CONDITIONAL(ENABLE_TROUSERS, test "$with_tpm" != "no")
|
||||
|
||||
-enable_local_libopts=no
|
||||
+included_libopts=no
|
||||
if test "$enable_tools" != "no" || test "$enable_doc" != "no"; then
|
||||
LIBOPTS_CHECK([src/libopts])
|
||||
if test "$NEED_LIBOPTS_DIR" = "true";then
|
||||
@@ -540,15 +540,17 @@ if test "$enable_tools" != "no" || test "$enable_doc" != "no"; then
|
||||
if test -z "$missing_baks"; then
|
||||
AC_SUBST([AUTOGEN], [/bin/true])
|
||||
fi
|
||||
- enable_local_libopts=yes
|
||||
+ included_libopts=yes
|
||||
fi
|
||||
else
|
||||
# Need to ensure the relevant conditionals get set
|
||||
gl_STDNORETURN_H
|
||||
AM_CONDITIONAL([INSTALL_LIBOPTS],[false])
|
||||
AM_CONDITIONAL([NEED_LIBOPTS], [false])
|
||||
+ included_libopts=yes
|
||||
fi
|
||||
-AM_CONDITIONAL(NEED_LIBOPTS, test "$enable_local_libopts" = "yes")
|
||||
+
|
||||
+AM_CONDITIONAL(NEED_LIBOPTS, test "$included_libopts" = "yes")
|
||||
|
||||
AC_CHECK_TYPE(ssize_t,
|
||||
[
|
||||
@@ -896,7 +898,7 @@ AC_MSG_NOTICE([summary of build options:
|
||||
Compiler: ${CC}
|
||||
CFlags: ${CFLAGS}
|
||||
Library types: Shared=${enable_shared}, Static=${enable_static}
|
||||
- Local libopts: ${enable_local_libopts}
|
||||
+ Local libopts: ${included_libopts}
|
||||
Local libtasn1: ${included_libtasn1}
|
||||
Use nettle-mini: ${mini_nettle}
|
||||
])
|
||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||
index 4105ab6..b907249 100644
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -30,13 +30,6 @@ if ENABLE_CRYWRAP
|
||||
SUBDIRS += crywrap
|
||||
endif
|
||||
|
||||
-if NEED_LIBOPTS
|
||||
-LIBOPTS = libopts/libopts.la
|
||||
-SUBDIRS += libopts
|
||||
-else
|
||||
-LIBOPTS = $(LIBOPTS_LDADD)
|
||||
-endif
|
||||
-
|
||||
EXTRA_DIST = args-std.def
|
||||
|
||||
AM_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
|
||||
@@ -49,6 +42,14 @@ AM_CPPFLAGS = \
|
||||
-I$(srcdir)/../extra/includes \
|
||||
$(LIBOPTS_CFLAGS)
|
||||
|
||||
+if NEED_LIBOPTS
|
||||
+LIBOPTS = libopts/libopts.la
|
||||
+SUBDIRS += libopts
|
||||
+AM_CPPFLAGS += -I$(srcdir)/libopts
|
||||
+else
|
||||
+LIBOPTS = $(LIBOPTS_LDADD)
|
||||
+endif
|
||||
+
|
||||
bin_PROGRAMS = psktool gnutls-cli-debug certtool
|
||||
if ENABLE_SRP
|
||||
bin_PROGRAMS += srptool
|
Loading…
Reference in a new issue