mariadb: Fix compilation without deprecated OpenSSL APIs
Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
c7426b1823
commit
2fa60e3e6d
2 changed files with 15 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=mariadb
|
||||
PKG_VERSION:=10.2.19
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=4
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL := \
|
||||
|
|
14
utils/mariadb/patches/200-openssl-deprecated.patch
Normal file
14
utils/mariadb/patches/200-openssl-deprecated.patch
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- a/libmariadb/libmariadb/secure/openssl.c
|
||||
+++ b/libmariadb/libmariadb/secure/openssl.c
|
||||
@@ -419,8 +419,10 @@ void ma_tls_end()
|
||||
if (mariadb_deinitialize_ssl)
|
||||
{
|
||||
#ifndef HAVE_OPENSSL_1_1_API
|
||||
-#if OPENSSL_VERSION_NUMBER < 0x10100000L
|
||||
+#if OPENSSL_VERSION_NUMBER < 0x10000000L
|
||||
ERR_remove_state(0);
|
||||
+#else
|
||||
+ ERR_remove_thread_state(NULL);
|
||||
#endif
|
||||
EVP_cleanup();
|
||||
CRYPTO_cleanup_all_ex_data();
|
Loading…
Reference in a new issue