diff --git a/net/e2guardian/Makefile b/net/e2guardian/Makefile
index 2628711ea..5fd458ae3 100644
--- a/net/e2guardian/Makefile
+++ b/net/e2guardian/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=e2guardian
 PKG_VERSION:=3.2.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_LICENSE:=GPL-2.0
 PKG_MAINTAINER:=Luka Perkov <luka@openwrt.org>
diff --git a/net/e2guardian/files/e2guardian.init b/net/e2guardian/files/e2guardian.init
index 4a5981e86..b4c236e40 100644
--- a/net/e2guardian/files/e2guardian.init
+++ b/net/e2guardian/files/e2guardian.init
@@ -11,7 +11,7 @@ LOGFILE="/tmp/e2guardian/access.log"
 GROUPCONFIG="/tmp/e2guardian/e2guardianf1.conf"
 
 validate_e2guardian_section() {
-	uci_validate_section e2guardian e2guardian "${1}" \
+	uci_load_validate e2guardian e2guardian "$1" "$2" \
 		'accessdeniedaddress:string' \
 		'bannediplist:string' \
 		'contentscanexceptions:string' \
@@ -83,22 +83,9 @@ validate_e2guardian_section() {
 		'weightedphrasemode:range(0,2)'
 }
 
-start_service() {
+start_e2guardian_instance() {
 
-	local accessdeniedaddress bannediplist contentscanexceptions contentscanner contentscannertimeout \
-		createlistcachefiles custombannedflashfile custombannedimagefile deletedownloadedtempfiles \
-		downloadmanager exceptioniplist filecachedir loglocation \
-		filtergroups filtergroupslist filterip filterports forcequicksearch forwardedfor hexdecodecontent \
-		initialtrickledelay ipcfilename ipipcfilename language languagedir logadblocks logchildprocesshandling \
-		logclienthostnames logconnectionhandlingerrors logexceptionhits logfileformat loglevel loguseragent \
-		maxagechildren maxchildren maxcontentfilecachescansize maxcontentfiltersize maxcontentramcachescansize \
-		maxips maxsparechildren maxuploadsize minchildren minsparechildren nodaemon nologger \
-		pcontimeout perroomdirectory phrasefiltermode prefercachedlists preforkchildren preservecase proxyexchange \
-		proxyip proxyport proxytimeout recheckreplacedurls reverseaddresslookups reverseclientiplookups scancleancache \
-		showweightedfound softrestart trickledelay urlcacheage urlcachenumber urlipcfilename usecustombannedflash \
-		usecustombannedimage usexforwardedfor weightedphrasemode
-
-	validate_e2guardian_section e2guardian || {
+	[ "$2" = 0 ] || {
 		echo "validation failed"
 		return 1
 	}
@@ -198,6 +185,11 @@ start_service() {
 
 }
 
+start_service()
+{
+	validate_e2guardian_section e2guardian start_e2guardian_instance
+}
+
 stop_service()
 {
 	PID=`cat /tmp/e2guardian/e2guardian.pid`