git: update to 2.8.2

Fixes:
 CVE-2016-2315
 CVE-2016-2324

Signed-off-by: Peter Wagner <tripolar@gmx.at>
This commit is contained in:
Peter Wagner 2016-05-13 12:54:35 +02:00
parent 47690a1027
commit 2edb2e36ec
4 changed files with 19 additions and 19 deletions

View file

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=git PKG_NAME:=git
PKG_VERSION:=2.7.3 PKG_VERSION:=2.8.2
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/software/scm/git/ PKG_SOURCE_URL:=@KERNEL/software/scm/git/
PKG_MD5SUM:=bb01710b1b24789a53c800a90c73957f PKG_MD5SUM:=b8edb4ae34828fda6aa2a4478089b107
PKG_INSTALL:=1 PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1 PKG_BUILD_PARALLEL:=1

View file

@ -1,6 +1,6 @@
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -559,16 +559,7 @@ EXTRA_PROGRAMS = @@ -574,16 +574,7 @@ EXTRA_PROGRAMS =
# ... and all the rest that could be moved out of bindir to gitexecdir # ... and all the rest that could be moved out of bindir to gitexecdir
PROGRAMS += $(EXTRA_PROGRAMS) PROGRAMS += $(EXTRA_PROGRAMS)
@ -17,7 +17,7 @@
# Binary suffix, set to .exe for Windows builds # Binary suffix, set to .exe for Windows builds
X = X =
@@ -929,6 +920,11 @@ BUILTIN_OBJS += builtin/verify-pack.o @@ -945,6 +936,11 @@ BUILTIN_OBJS += builtin/verify-pack.o
BUILTIN_OBJS += builtin/verify-tag.o BUILTIN_OBJS += builtin/verify-tag.o
BUILTIN_OBJS += builtin/worktree.o BUILTIN_OBJS += builtin/worktree.o
BUILTIN_OBJS += builtin/write-tree.o BUILTIN_OBJS += builtin/write-tree.o
@ -29,7 +29,7 @@
GITLIBS = $(LIB_FILE) $(XDIFF_LIB) GITLIBS = $(LIB_FILE) $(XDIFF_LIB)
EXTLIBS = EXTLIBS =
@@ -1112,7 +1108,7 @@ endif @@ -1128,7 +1124,7 @@ endif
EXTLIBS += -lz EXTLIBS += -lz
ifndef NO_OPENSSL ifndef NO_OPENSSL
@ -38,7 +38,7 @@
ifdef OPENSSLDIR ifdef OPENSSLDIR
BASIC_CFLAGS += -I$(OPENSSLDIR)/include BASIC_CFLAGS += -I$(OPENSSLDIR)/include
OPENSSL_LINK = -L$(OPENSSLDIR)/$(lib) $(CC_LD_DYNPATH)$(OPENSSLDIR)/$(lib) OPENSSL_LINK = -L$(OPENSSLDIR)/$(lib) $(CC_LD_DYNPATH)$(OPENSSLDIR)/$(lib)
@@ -1989,10 +1985,6 @@ endif @@ -2006,10 +2002,6 @@ endif
git-%$X: %.o GIT-LDFLAGS $(GITLIBS) git-%$X: %.o GIT-LDFLAGS $(GITLIBS)
$(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) $(LIBS) $(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) $(LIBS)
@ -49,7 +49,7 @@
git-http-fetch$X: http.o http-walker.o http-fetch.o GIT-LDFLAGS $(GITLIBS) git-http-fetch$X: http.o http-walker.o http-fetch.o GIT-LDFLAGS $(GITLIBS)
$(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) \ $(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) \
$(CURL_LIBCURL) $(LIBS) $(CURL_LIBCURL) $(LIBS)
@@ -2312,10 +2304,11 @@ endif @@ -2332,10 +2324,11 @@ endif
bindir=$$(cd '$(DESTDIR_SQ)$(bindir_SQ)' && pwd) && \ bindir=$$(cd '$(DESTDIR_SQ)$(bindir_SQ)' && pwd) && \
execdir=$$(cd '$(DESTDIR_SQ)$(gitexec_instdir_SQ)' && pwd) && \ execdir=$$(cd '$(DESTDIR_SQ)$(gitexec_instdir_SQ)' && pwd) && \
{ test "$$bindir/" = "$$execdir/" || \ { test "$$bindir/" = "$$execdir/" || \
@ -127,7 +127,7 @@
--- a/git.c --- a/git.c
+++ b/git.c +++ b/git.c
@@ -307,11 +307,11 @@ static int handle_alias(int *argcp, cons @@ -313,11 +313,11 @@ static int handle_alias(int *argcp, cons
struct cmd_struct { struct cmd_struct {
const char *cmd; const char *cmd;
@ -141,7 +141,7 @@
{ {
int status, help; int status, help;
struct stat st; struct stat st;
@@ -392,6 +392,7 @@ static struct cmd_struct commands[] = { @@ -398,6 +398,7 @@ static struct cmd_struct commands[] = {
{ "config", cmd_config, RUN_SETUP_GENTLY }, { "config", cmd_config, RUN_SETUP_GENTLY },
{ "count-objects", cmd_count_objects, RUN_SETUP }, { "count-objects", cmd_count_objects, RUN_SETUP },
{ "credential", cmd_credential, RUN_SETUP_GENTLY }, { "credential", cmd_credential, RUN_SETUP_GENTLY },
@ -149,15 +149,15 @@
{ "describe", cmd_describe, RUN_SETUP }, { "describe", cmd_describe, RUN_SETUP },
{ "diff", cmd_diff }, { "diff", cmd_diff },
{ "diff-files", cmd_diff_files, RUN_SETUP | NEED_WORK_TREE }, { "diff-files", cmd_diff_files, RUN_SETUP | NEED_WORK_TREE },
@@ -410,6 +411,7 @@ static struct cmd_struct commands[] = { @@ -416,6 +417,7 @@ static struct cmd_struct commands[] = {
{ "grep", cmd_grep, RUN_SETUP_GENTLY }, { "grep", cmd_grep, RUN_SETUP_GENTLY },
{ "hash-object", cmd_hash_object }, { "hash-object", cmd_hash_object },
{ "help", cmd_help }, { "help", cmd_help },
+ { "imap-send", cmd_imap_send }, + { "imap-send", cmd_imap_send },
{ "index-pack", cmd_index_pack, RUN_SETUP_GENTLY }, { "index-pack", cmd_index_pack, RUN_SETUP_GENTLY },
{ "init", cmd_init_db, NO_SETUP }, { "init", cmd_init_db },
{ "init-db", cmd_init_db, NO_SETUP }, { "init-db", cmd_init_db },
@@ -459,6 +461,7 @@ static struct cmd_struct commands[] = { @@ -465,6 +467,7 @@ static struct cmd_struct commands[] = {
{ "revert", cmd_revert, RUN_SETUP | NEED_WORK_TREE }, { "revert", cmd_revert, RUN_SETUP | NEED_WORK_TREE },
{ "rm", cmd_rm, RUN_SETUP }, { "rm", cmd_rm, RUN_SETUP },
{ "send-pack", cmd_send_pack, RUN_SETUP }, { "send-pack", cmd_send_pack, RUN_SETUP },
@ -165,7 +165,7 @@
{ "shortlog", cmd_shortlog, RUN_SETUP_GENTLY | USE_PAGER }, { "shortlog", cmd_shortlog, RUN_SETUP_GENTLY | USE_PAGER },
{ "show", cmd_show, RUN_SETUP }, { "show", cmd_show, RUN_SETUP },
{ "show-branch", cmd_show_branch, RUN_SETUP }, { "show-branch", cmd_show_branch, RUN_SETUP },
@@ -476,6 +479,7 @@ static struct cmd_struct commands[] = { @@ -482,6 +485,7 @@ static struct cmd_struct commands[] = {
{ "update-server-info", cmd_update_server_info, RUN_SETUP }, { "update-server-info", cmd_update_server_info, RUN_SETUP },
{ "upload-archive", cmd_upload_archive }, { "upload-archive", cmd_upload_archive },
{ "upload-archive--writer", cmd_upload_archive_writer }, { "upload-archive--writer", cmd_upload_archive_writer },
@ -197,7 +197,7 @@
const char **user_argv; const char **user_argv;
--- a/upload-pack.c --- a/upload-pack.c
+++ b/upload-pack.c +++ b/upload-pack.c
@@ -820,7 +820,7 @@ static int upload_pack_config(const char @@ -817,7 +817,7 @@ static int upload_pack_config(const char
return parse_hide_refs_config(var, value, "uploadpack"); return parse_hide_refs_config(var, value, "uploadpack");
} }

View file

@ -1,6 +1,6 @@
--- a/configure.ac --- a/configure.ac
+++ b/configure.ac +++ b/configure.ac
@@ -860,7 +860,8 @@ AC_RUN_IFELSE( @@ -867,7 +867,8 @@ AC_RUN_IFELSE(
FILE *f = fopen(".", "r"); FILE *f = fopen(".", "r");
return f && fread(&c, 1, 1, f)]])], return f && fread(&c, 1, 1, f)]])],
[ac_cv_fread_reads_directories=no], [ac_cv_fread_reads_directories=no],
@ -10,7 +10,7 @@
]) ])
if test $ac_cv_fread_reads_directories = yes; then if test $ac_cv_fread_reads_directories = yes; then
FREAD_READS_DIRECTORIES=UnfortunatelyYes FREAD_READS_DIRECTORIES=UnfortunatelyYes
@@ -894,7 +895,8 @@ AC_RUN_IFELSE( @@ -901,7 +902,8 @@ AC_RUN_IFELSE(
if (snprintf(buf, 3, "%s", "12345") != 5 if (snprintf(buf, 3, "%s", "12345") != 5
|| strcmp(buf, "12")) return 1]])], || strcmp(buf, "12")) return 1]])],
[ac_cv_snprintf_returns_bogus=no], [ac_cv_snprintf_returns_bogus=no],
@ -20,7 +20,7 @@
]) ])
if test $ac_cv_snprintf_returns_bogus = yes; then if test $ac_cv_snprintf_returns_bogus = yes; then
SNPRINTF_RETURNS_BOGUS=UnfortunatelyYes SNPRINTF_RETURNS_BOGUS=UnfortunatelyYes
@@ -917,7 +919,8 @@ yippeeyeswehaveit @@ -924,7 +926,8 @@ yippeeyeswehaveit
#endif #endif
]), ]),
[ac_cv_sane_mode_bits=yes], [ac_cv_sane_mode_bits=yes],

View file

@ -1,6 +1,6 @@
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -1080,7 +1080,7 @@ else @@ -1096,7 +1096,7 @@ else
endif endif
curl_check := $(shell (echo 072200; $(CURL_CONFIG) --vernum | sed -e '/^70[BC]/s/^/0/') 2>/dev/null | sort -r | sed -ne 2p) curl_check := $(shell (echo 072200; $(CURL_CONFIG) --vernum | sed -e '/^70[BC]/s/^/0/') 2>/dev/null | sort -r | sed -ne 2p)
ifeq "$(curl_check)" "072200" ifeq "$(curl_check)" "072200"