libevhtp: update to version 1.2.10
Signed-off-by: Gergely Kiss <mail.gery@gmail.com>
This commit is contained in:
parent
a45bcefe93
commit
2e9d2f3faf
2 changed files with 3 additions and 52 deletions
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2007-2014 OpenWrt.org
|
||||
# Copyright (C) 2007-2015 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libevhtp
|
||||
PKG_VERSION:=1.2.9
|
||||
PKG_VERSION:=1.2.10
|
||||
PKG_RELEASE:=1
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
|
||||
PKG_SOURCE:=$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/ellzey/libevhtp/archive/
|
||||
PKG_MD5SUM:=428a8d179fcc0cadedd914ed6456e08f
|
||||
PKG_MD5SUM:=e7261c7e34654f78047431d169b88806
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
||||
|
|
|
@ -1,49 +0,0 @@
|
|||
diff -rupN libevhtp-1.2.9.orig/htparse/htparse.c libevhtp-1.2.9/htparse/htparse.c
|
||||
--- libevhtp-1.2.9.orig/htparse/htparse.c 2014-03-23 12:50:50.000000000 +0100
|
||||
+++ libevhtp-1.2.9/htparse/htparse.c 2014-12-09 01:12:22.242001241 +0100
|
||||
@@ -197,6 +197,7 @@ static const char * method_strmap[] = {
|
||||
|
||||
#define _MIN_READ(a, b) ((a) < (b) ? (a) : (b))
|
||||
|
||||
+#if __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
|
||||
#define _str3_cmp(m, c0, c1, c2, c3) \
|
||||
*(uint32_t *)m == ((c3 << 24) | (c2 << 16) | (c1 << 8) | c0)
|
||||
|
||||
@@ -226,6 +227,37 @@ static const char * method_strmap[] = {
|
||||
*(uint32_t *)m == ((c3 << 24) | (c2 << 16) | (c1 << 8) | c0) \
|
||||
&& ((uint32_t *)m)[1] == ((c7 << 24) | (c6 << 16) | (c5 << 8) | c4) \
|
||||
&& m[8] == c8
|
||||
+#elif __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__
|
||||
+#define _str3_cmp(m, c0, c1, c2, c3) \
|
||||
+ *(uint32_t *)m == ((c0 << 24) | (c1 << 16) | (c2 << 8) | c3)
|
||||
+
|
||||
+#define _str3Ocmp(m, c0, c1, c2, c3) \
|
||||
+ *(uint32_t *)m == ((c0 << 24) | (c1 << 16) | (c2 << 8) | c3)
|
||||
+
|
||||
+#define _str4cmp(m, c0, c1, c2, c3) \
|
||||
+ *(uint32_t *)m == ((c0 << 24) | (c1 << 16) | (c2 << 8) | c3)
|
||||
+
|
||||
+#define _str5cmp(m, c0, c1, c2, c3, c4) \
|
||||
+ *(uint32_t *)m == ((c0 << 24) | (c1 << 16) | (c2 << 8) | c3) \
|
||||
+ && m[4] == c4
|
||||
+
|
||||
+#define _str6cmp(m, c0, c1, c2, c3, c4, c5) \
|
||||
+ *(uint32_t *)m == ((c0 << 24) | (c1 << 16) | (c2 << 8) | c3) \
|
||||
+ && (((uint32_t *)m)[1] & 0xffff0000) == ((c4 << 24) | c5 << 16)
|
||||
+
|
||||
+#define _str7_cmp(m, c0, c1, c2, c3, c4, c5, c6, c7) \
|
||||
+ *(uint32_t *)m == ((c0 << 24) | (c1 << 16) | (c2 << 8) | c3) \
|
||||
+ && ((uint32_t *)m)[1] == ((c4 << 24) | (c5 << 16) | (c6 << 8) | c7)
|
||||
+
|
||||
+#define _str8cmp(m, c0, c1, c2, c3, c4, c5, c6, c7) \
|
||||
+ *(uint32_t *)m == ((c0 << 24) | (c1 << 16) | (c2 << 8) | c3) \
|
||||
+ && ((uint32_t *)m)[1] == ((c4 << 24) | (c5 << 16) | (c6 << 8) | c7)
|
||||
+
|
||||
+#define _str9cmp(m, c0, c1, c2, c3, c4, c5, c6, c7, c8) \
|
||||
+ *(uint32_t *)m == ((c0 << 24) | (c1 << 16) | (c2 << 8) | c3) \
|
||||
+ && ((uint32_t *)m)[1] == ((c4 << 24) | (c5 << 16) | (c6 << 8) | c7) \
|
||||
+ && m[8] == c8
|
||||
+#endif
|
||||
|
||||
#define __HTPARSE_GENHOOK(__n) \
|
||||
static inline int hook_ ## __n ## _run(htparser * p, htparse_hooks * hooks) { \
|
Loading…
Reference in a new issue