sumo: update to 1.7.0
Remove CMAKE_INSTALL as there is no need for InstallDev. Remove unneeded patches. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
4fe39a4e2f
commit
2e52916c28
3 changed files with 2 additions and 103 deletions
|
@ -8,18 +8,16 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=sumo
|
||||
PKG_VERSION:=1.3.1
|
||||
PKG_VERSION:=1.7.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-src-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/sumo
|
||||
PKG_HASH:=dd089814499cc8d21ea90ab506adbb01e7fda9d9685d9d90a1a41cc3fe680505
|
||||
PKG_HASH:=1f7a668568c92d1eeaa0e54a8af45052747accf9ba42983b21e906a80b16a9c2
|
||||
|
||||
PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
|
||||
PKG_LICENSE:=GPL-3.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
CMAKE_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
|
|
@ -1,73 +0,0 @@
|
|||
From d35215b50bfea42c8a1d884c65fda1dee8b62d50 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Behrisch <michael.behrisch@dlr.de>
|
||||
Date: Fri, 4 Oct 2019 11:41:29 +0200
|
||||
Subject: [PATCH] removing usleep, refs #12, fix #6133
|
||||
|
||||
---
|
||||
src/utils/foxtools/FXSingleEventThread.cpp | 9 +++------
|
||||
src/utils/iodevices/OutputDevice_Network.cpp | 17 ++++-------------
|
||||
2 files changed, 7 insertions(+), 19 deletions(-)
|
||||
|
||||
diff --git a/src/utils/foxtools/FXSingleEventThread.cpp b/src/utils/foxtools/FXSingleEventThread.cpp
|
||||
index 4b12fb920f..f545c18439 100644
|
||||
--- a/src/utils/foxtools/FXSingleEventThread.cpp
|
||||
+++ b/src/utils/foxtools/FXSingleEventThread.cpp
|
||||
@@ -35,6 +35,8 @@
|
||||
#else
|
||||
#include <process.h>
|
||||
#endif
|
||||
+#include <chrono>
|
||||
+#include <thread>
|
||||
|
||||
#ifndef WIN32
|
||||
# define PIPE_READ 0
|
||||
@@ -137,12 +139,7 @@ FXSingleEventThread::onThreadEvent(FXObject*, FXSelector, void*) {
|
||||
|
||||
void
|
||||
FXSingleEventThread::sleep(long ms) {
|
||||
-#ifdef WIN32
|
||||
- Sleep(ms);
|
||||
-#else
|
||||
- long long us = ms * 1000;
|
||||
- usleep(us);
|
||||
-#endif
|
||||
+ std::this_thread::sleep_for(std::chrono::milliseconds(ms));
|
||||
}
|
||||
|
||||
|
||||
diff --git a/src/utils/iodevices/OutputDevice_Network.cpp b/src/utils/iodevices/OutputDevice_Network.cpp
|
||||
index 2c20ce96aa..6bde32e1e6 100644
|
||||
--- a/src/utils/iodevices/OutputDevice_Network.cpp
|
||||
+++ b/src/utils/iodevices/OutputDevice_Network.cpp
|
||||
@@ -21,15 +21,10 @@
|
||||
// ==========================================================================
|
||||
// included modules
|
||||
// ==========================================================================
|
||||
-#include <config.h> // #ifdef _MSC_VER
|
||||
+#include <config.h>
|
||||
|
||||
-#ifdef WIN32
|
||||
-#define NOMINMAX
|
||||
-#include <windows.h>
|
||||
-#undef NOMINMAX
|
||||
-#else
|
||||
-#include <unistd.h>
|
||||
-#endif
|
||||
+#include <thread>
|
||||
+#include <chrono>
|
||||
#include <vector>
|
||||
#include "OutputDevice_Network.h"
|
||||
#include "foreign/tcpip/socket.h"
|
||||
@@ -57,11 +52,7 @@ OutputDevice_Network::OutputDevice_Network(const std::string& host,
|
||||
if (wait == 9000) {
|
||||
throw IOError(toString(e.what()) + " (host: " + host + ", port: " + toString(port) + ")");
|
||||
}
|
||||
-#ifdef WIN32
|
||||
- Sleep(wait);
|
||||
-#else
|
||||
- usleep(wait * 1000);
|
||||
-#endif
|
||||
+ std::this_thread::sleep_for(std::chrono::milliseconds(wait));
|
||||
}
|
||||
}
|
||||
myFilename = host + ":" + toString(port);
|
|
@ -1,26 +0,0 @@
|
|||
--- a/src/foreign/zstr/strict_fstream.hpp
|
||||
+++ b/src/foreign/zstr/strict_fstream.hpp
|
||||
@@ -33,17 +33,17 @@ static std::string strerror()
|
||||
{
|
||||
buff = "Unknown error";
|
||||
}
|
||||
-#elif __APPLE__ || ((_POSIX_C_SOURCE >= 200112L || _XOPEN_SOURCE >= 600) && ! _GNU_SOURCE)
|
||||
+#elif defined(__GLIBC__)
|
||||
+// GNU-specific strerror_r()
|
||||
+ auto p = strerror_r(errno, &buff[0], buff.size());
|
||||
+ std::string tmp(p, std::strlen(p));
|
||||
+ std::swap(buff, tmp);
|
||||
+#else
|
||||
// XSI-compliant strerror_r()
|
||||
if (strerror_r(errno, &buff[0], buff.size()) != 0)
|
||||
{
|
||||
buff = "Unknown error";
|
||||
}
|
||||
-#else
|
||||
-// GNU-specific strerror_r()
|
||||
- auto p = strerror_r(errno, &buff[0], buff.size());
|
||||
- std::string tmp(p, std::strlen(p));
|
||||
- std::swap(buff, tmp);
|
||||
#endif
|
||||
buff.resize(buff.find('\0'));
|
||||
return buff;
|
Loading…
Reference in a new issue