gammu: Update to 1.40.0
Cleaned up Makefile for consistency between packages. Switched to CMAKE_INSTALL to get rid of the InstallDev section. Refreshed patches. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
3afa70ddea
commit
2e2929366b
6 changed files with 19 additions and 30 deletions
|
@ -9,18 +9,19 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gammu
|
||||
PKG_VERSION:=1.39.0
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=1.40.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_URL:=https://dl.cihar.com/gammu/releases
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_HASH:=66d1d991d7a993fdf254d4c425f0fdd38c9cca15b1735936695a486067a6a9f8
|
||||
PKG_SOURCE_URL:=https://dl.cihar.com/gammu/releases
|
||||
PKG_HASH:=a760a3520d9f3a16a4ed73cefaabdbd86125bec73c6fa056ca3f0a4be8478dd6
|
||||
|
||||
PKG_MAINTAINER:=Vitaly Protsko <villy@sft.ru>
|
||||
PKG_LICENCE:=GPL-2.0
|
||||
PKG_LICENCE:=GPL-2.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
CMAKE_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
|
@ -48,13 +49,6 @@ CMAKE_OPTIONS += -DICONV_INCLUDE_DIRS:PATH=$(ICONV_PREFIX)/include
|
|||
CMAKE_OPTIONS += -DICONV_LIBRARIES:STRING=iconv
|
||||
endif
|
||||
|
||||
define Build/InstallDev
|
||||
mkdir -p $(1)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/gammu $(1)/usr/include/
|
||||
mkdir -p $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{Gammu*,gsmsd*} $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Package/gammu/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gammu $(1)/usr/bin
|
||||
|
|
|
@ -1,5 +1,3 @@
|
|||
diff --git a/cmake/FindIconv.cmake b/cmake/FindIconv.cmake
|
||||
index 3ec0493..f716700 100644
|
||||
--- a/cmake/FindIconv.cmake
|
||||
+++ b/cmake/FindIconv.cmake
|
||||
@@ -9,10 +9,10 @@
|
||||
|
@ -15,8 +13,6 @@ index 3ec0493..f716700 100644
|
|||
|
||||
IF(APPLE)
|
||||
FIND_PATH(ICONV_INCLUDE_DIR iconv.h
|
||||
diff --git a/configure b/configure
|
||||
index 4f51ca7..5b0d993 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -33,6 +33,7 @@ Usage: ./configure [options]
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -511,8 +511,6 @@ if(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMP
|
||||
# MACRO_TUNE_LINKER("-pie")
|
||||
# These do not work on Windows right now
|
||||
if (NOT WIN32)
|
||||
- # Stack protector
|
||||
- MACRO_TUNE_COMPILER("-fstack-protector")
|
||||
# Mark code read only
|
||||
MACRO_TUNE_LINKER("-Wl,-zrelro")
|
||||
endif (NOT WIN32)
|
|
@ -16,7 +16,7 @@
|
|||
--enable-shared enables shared build
|
||||
--enable-debug enables debug build
|
||||
--enable-tiger enables Mac OS X 10.4 (Tiger) build
|
||||
@@ -51,6 +52,7 @@ SOURCE_DIR=`pwd`
|
||||
@@ -51,6 +52,7 @@ BUILD_DIR="$SOURCE_DIR/build-configure"
|
||||
|
||||
# cmake parameters
|
||||
CMAKE_PREFIX=
|
||||
|
|
|
@ -8,7 +8,7 @@
|
|||
|
||||
All enable params have their disable counterparts.
|
||||
|
||||
@@ -61,6 +62,7 @@ CMAKE_PYTHON=
|
||||
@@ -61,6 +62,7 @@ CMAKE_PROTECTION=
|
||||
CMAKE_GNAP=
|
||||
CMAKE_COMPLETE=
|
||||
CMAKE_ICONV=
|
||||
|
|
10
utils/gammu/patches/020-select.patch
Normal file
10
utils/gammu/patches/020-select.patch
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- a/libgammu/device/devfunc.c
|
||||
+++ b/libgammu/device/devfunc.c
|
||||
@@ -24,6 +24,7 @@
|
||||
# include <signal.h>
|
||||
# include <sys/socket.h>
|
||||
# include <sys/stat.h>
|
||||
+# include <sys/select.h>
|
||||
#endif
|
||||
|
||||
#include "devfunc.h"
|
Loading…
Reference in a new issue