horst: fix compilation with ncurses 6.3
Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
2819935d99
commit
2bf3d9a777
2 changed files with 23 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=horst
|
||||
PKG_VERSION:=5.1
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=4
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/br101/horst/archive/v$(PKG_VERSION)/
|
||||
|
|
22
net/horst/patches/010-ncurses63.patch
Normal file
22
net/horst/patches/010-ncurses63.patch
Normal file
|
@ -0,0 +1,22 @@
|
|||
--- a/display-main.c
|
||||
+++ b/display-main.c
|
||||
@@ -53,7 +53,7 @@ static struct ewma bpsn_avg;
|
||||
void print_dump_win(const char *str, int refresh)
|
||||
{
|
||||
wattron(dump_win, RED);
|
||||
- wprintw(dump_win, str);
|
||||
+ wprintw(dump_win, "%s", str);
|
||||
wattroff(dump_win, RED);
|
||||
if (refresh)
|
||||
wrefresh(dump_win);
|
||||
--- a/display.c
|
||||
+++ b/display.c
|
||||
@@ -86,7 +86,7 @@ print_centered(WINDOW* win, int line, in
|
||||
vsnprintf(buf, cols, fmt, ap);
|
||||
va_end(ap);
|
||||
|
||||
- mvwprintw(win, line, cols / 2 - strlen(buf) / 2, buf);
|
||||
+ mvwprintw(win, line, cols / 2 - strlen(buf) / 2, "%s", buf);
|
||||
free(buf);
|
||||
}
|
||||
|
Loading…
Reference in a new issue