mdnsresponder: fix fd leak for IPv6 sockets
Signed-off-by: Steven Barth <steven@midlink.org>
This commit is contained in:
parent
e7c01b17df
commit
2bcaf5fc70
2 changed files with 6 additions and 3 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=mDNSResponder
|
||||
PKG_VERSION:=567
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=mDNSResponder-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://opensource.apple.com/tarballs/mDNSResponder/
|
||||
|
|
|
@ -313,7 +313,7 @@ index 6effa12..7c1d6eb 100755
|
|||
}
|
||||
|
||||
diff --git a/mDNSPosix/mDNSUNP.c b/mDNSPosix/mDNSUNP.c
|
||||
index b392fc7..fe800af 100755
|
||||
index b392fc7..f551ad5 100755
|
||||
--- a/mDNSPosix/mDNSUNP.c
|
||||
+++ b/mDNSPosix/mDNSUNP.c
|
||||
@@ -63,6 +63,7 @@
|
||||
|
@ -357,9 +357,12 @@ index b392fc7..fe800af 100755
|
|||
myflags = 0;
|
||||
if (strncmp(lastname, ifname, IFNAMSIZ) == 0) {
|
||||
if (doaliases == 0)
|
||||
@@ -205,7 +208,8 @@ gotError:
|
||||
@@ -204,8 +207,11 @@ gotError:
|
||||
res0=NULL;
|
||||
}
|
||||
done:
|
||||
+ if (fp)
|
||||
+ fclose(fp);
|
||||
if (sockfd != -1) {
|
||||
- assert(close(sockfd) == 0);
|
||||
+ int rv = close(sockfd);
|
||||
|
|
Loading…
Reference in a new issue