knot-resolver: update to 5.4.2
* refresh patches * disabling kres_gen_test is not required anymore for cross compilation, it was fixed upstream with the 5.4.1 release Signed-off-by: Michal Vasilek <michal.vasilek@nic.cz>
This commit is contained in:
parent
b22aa5b9e6
commit
2b3b2ffe42
2 changed files with 3 additions and 5 deletions
|
@ -10,12 +10,12 @@ PKG_RELRO_FULL:=0
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=knot-resolver
|
PKG_NAME:=knot-resolver
|
||||||
PKG_VERSION:=5.4.0
|
PKG_VERSION:=5.4.2
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=https://secure.nic.cz/files/knot-resolver
|
PKG_SOURCE_URL:=https://secure.nic.cz/files/knot-resolver
|
||||||
PKG_HASH:=534af671b98433b23b57039acc9d7d3c100a4888a8cf9aeba36161774ca0815e
|
PKG_HASH:=ea6a219571a752056669bae3f2c0c3ed0bec58af5ab832d505a3ec9c4063a58b
|
||||||
|
|
||||||
PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec1@gmail.com>
|
PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec1@gmail.com>
|
||||||
PKG_LICENSE:=GPL-3.0-later
|
PKG_LICENSE:=GPL-3.0-later
|
||||||
|
@ -56,7 +56,6 @@ define Package/knot-resolver/config
|
||||||
source "$(SOURCE)/Config.in"
|
source "$(SOURCE)/Config.in"
|
||||||
endef
|
endef
|
||||||
|
|
||||||
# kres_gen_test breaks on cross, fix is already upstream
|
|
||||||
MESON_ARGS+= \
|
MESON_ARGS+= \
|
||||||
$(if $(CONFIG_PACKAGE_knot-resolver_dnstap), -Ddnstap=enabled,-Ddnstap=disabled) \
|
$(if $(CONFIG_PACKAGE_knot-resolver_dnstap), -Ddnstap=enabled,-Ddnstap=disabled) \
|
||||||
-Dcapng=disabled \
|
-Dcapng=disabled \
|
||||||
|
@ -69,7 +68,6 @@ MESON_ARGS+= \
|
||||||
-Dkeyfile_default=/etc/knot-resolver/root.keys \
|
-Dkeyfile_default=/etc/knot-resolver/root.keys \
|
||||||
-Dprefix=/usr \
|
-Dprefix=/usr \
|
||||||
-Dunit_tests=disabled \
|
-Dunit_tests=disabled \
|
||||||
-Dkres_gen_test=false \
|
|
||||||
-Dutils=disabled
|
-Dutils=disabled
|
||||||
|
|
||||||
define Package/knot-resolver/install
|
define Package/knot-resolver/install
|
||||||
|
|
|
@ -2,7 +2,7 @@ This patch fixes the problem with forwarding in knot-resolver v4.3.0.
|
||||||
It reintroduces a fix which enables policy related hack (knot/knot-resolver#205 (comment 94566) )
|
It reintroduces a fix which enables policy related hack (knot/knot-resolver#205 (comment 94566) )
|
||||||
--- a/modules/policy/policy.lua
|
--- a/modules/policy/policy.lua
|
||||||
+++ b/modules/policy/policy.lua
|
+++ b/modules/policy/policy.lua
|
||||||
@@ -984,7 +984,7 @@ policy.layer = {
|
@@ -1000,7 +1000,7 @@ policy.layer = {
|
||||||
if bit.band(state, bit.bor(kres.FAIL, kres.DONE)) ~= 0 then return state end
|
if bit.band(state, bit.bor(kres.FAIL, kres.DONE)) ~= 0 then return state end
|
||||||
local qry = req:initial() -- same as :current() but more descriptive
|
local qry = req:initial() -- same as :current() but more descriptive
|
||||||
return policy.evaluate(policy.rules, req, qry, state)
|
return policy.evaluate(policy.rules, req, qry, state)
|
||||||
|
|
Loading…
Reference in a new issue