Merge pull request #1923 from hnyman/libtorrent
Libtorrent and rtorrent: update version, disable ipv6 to fix compilation Signed-off-by: Peter Wagner <tripolar@gmx.at>
This commit is contained in:
commit
2a5d519d01
4 changed files with 9 additions and 35 deletions
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2007-2013 OpenWrt.org
|
||||
# Copyright (C) 2007-2015 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libtorrent
|
||||
PKG_VERSION:=0.13.4-git-1
|
||||
PKG_VERSION:=0.13.6-git-1
|
||||
PKG_RELEASE=$(PKG_SOURCE_VERSION)
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/rakshasa/libtorrent.git
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=72e908707f01ee01a9b4918436c64348878b63f7
|
||||
PKG_SOURCE_VERSION:=14e793b75dac95c51ad64ff9cd2dc6772b68c625
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
@ -50,7 +50,7 @@ CONFIGURE_ARGS+= \
|
|||
--enable-openssl \
|
||||
--disable-instrumentation \
|
||||
--with-zlib=$(STAGING_DIR)/usr \
|
||||
$(call autoconf_bool,CONFIG_IPV6,ipv6)
|
||||
--disable-ipv6
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
--- a/src/net/socket_datagram.cc
|
||||
+++ b/src/net/socket_datagram.cc
|
||||
@@ -73,6 +73,23 @@ SocketDatagram::write_datagram(const voi
|
||||
int r;
|
||||
|
||||
if (sa != NULL) {
|
||||
+#ifdef RAK_USE_INET6
|
||||
+ if (m_ipv6_socket && sa->family() == rak::socket_address::pf_inet) {
|
||||
+ uint32_t addr32[4];
|
||||
+ sockaddr_in6 mapped_addr;
|
||||
+ memset(&mapped_addr, 0, sizeof(mapped_addr));
|
||||
+ mapped_addr.sin6_family = AF_INET6;
|
||||
+ addr32[0] = 0;
|
||||
+ addr32[1] = 0;
|
||||
+ addr32[2] = htonl(0xffff);
|
||||
+ addr32[3] = sa->sa_inet()->address_n();
|
||||
+ memcpy(mapped_addr.sin6_addr.s6_addr, addr32, sizeof(uint32_t) * 4);
|
||||
+ mapped_addr.sin6_port = sa->sa_inet()->port_n();
|
||||
+ r = ::sendto(m_fileDesc, buffer, length, 0, (sockaddr*)&mapped_addr, sizeof(mapped_addr));
|
||||
+ } else if (m_ipv6_socket && sa->family() == rak::socket_address::pf_inet6) {
|
||||
+ r = ::sendto(m_fileDesc, buffer, length, 0, sa->sa_inet6()->c_sockaddr(), sizeof(rak::socket_address_inet6));
|
||||
+ } else
|
||||
+#endif
|
||||
r = ::sendto(m_fileDesc, buffer, length, 0, sa->sa_inet()->c_sockaddr(), sizeof(rak::socket_address_inet));
|
||||
} else {
|
||||
r = ::send(m_fileDesc, buffer, length, 0);
|
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2007-2013 OpenWrt.org
|
||||
# Copyright (C) 2007-2015 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=rtorrent
|
||||
PKG_VERSION:=0.9.4-git-1
|
||||
PKG_VERSION:=0.9.6-git-1
|
||||
PKG_RELEASE=$(PKG_SOURCE_VERSION)
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/rakshasa/rtorrent.git
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=7343e33a6a0d279179b304a380bf011f1c8be64a
|
||||
PKG_SOURCE_VERSION:=62cb5a4605c0664bc522e0e0da9c72f09cf643a9
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
||||
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
|
@ -73,7 +73,7 @@ CONFIGURE_ARGS+= \
|
|||
--enable-shared \
|
||||
--disable-static \
|
||||
--disable-debug \
|
||||
$(call autoconf_bool,CONFIG_IPV6,ipv6)
|
||||
--disable-ipv6
|
||||
|
||||
ifeq ($(BUILD_VARIANT),rpc)
|
||||
CONFIGURE_ARGS += \
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -4,7 +4,6 @@ AC_DEFINE(API_VERSION, 8, api version)
|
||||
@@ -4,7 +4,6 @@ AC_DEFINE(API_VERSION, 9, api version)
|
||||
|
||||
AM_INIT_AUTOMAKE
|
||||
AC_CONFIG_HEADERS(config.h)
|
||||
|
|
Loading…
Reference in a new issue