Merge pull request #6296 from cotequeiroz/rp-pppoe-glibc

rp-pppoe: redo glibc patch
This commit is contained in:
Hans Dedecker 2018-06-14 17:34:04 +02:00 committed by GitHub
commit 29a46cff81
No known key found for this signature in database
GPG key ID: 4AEE18F83AFDEB23
2 changed files with 5 additions and 5 deletions

View file

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=rp-pppoe
PKG_VERSION:=3.12
PKG_RELEASE:=5
PKG_RELEASE:=6
PKG_MAINTAINER:=Daniel Dickinson <lede@cshore.thecshore.com>
PKG_LICENSE:=LGPL-2.0+

View file

@ -1,12 +1,12 @@
--- a/src/pppoe.h
+++ b/src/pppoe.h
@@ -131,7 +131,9 @@ typedef unsigned long UINT32_t;
#include <linux/if_ether.h>
@@ -132,6 +132,9 @@ typedef unsigned long UINT32_t;
#endif
+#ifndef __GLIBC__
#include <netinet/in.h>
+#endif
+/* avoid redefinitions if <linux/in.h> and <linux/in6.h> get included. */
+#define _LINUX_IN_H
+#define _LINUX_IN6_H
#ifdef HAVE_NETINET_IF_ETHER_H
#include <sys/types.h>