zmq: Update to 4.1.6
Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
510ea619a4
commit
299344694e
3 changed files with 7 additions and 7 deletions
|
@ -10,15 +10,15 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=zeromq
|
PKG_NAME:=zeromq
|
||||||
PKG_VERSION:=4.1.4
|
PKG_VERSION:=4.1.6
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
|
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
|
||||||
PKG_LICENSE:=GPL-3.0+
|
PKG_LICENSE:=GPL-3.0+
|
||||||
PKG_LICENSE_FILES:=LICENCE.txt
|
PKG_LICENSE_FILES:=LICENCE.txt
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:= https://github.com/zeromq/zeromq4-1/releases/download/v$(PKG_VERSION)/
|
PKG_SOURCE_URL:=https://github.com/zeromq/zeromq4-1/releases/download/v$(PKG_VERSION)
|
||||||
PKG_HASH:=e99f44fde25c2e4cb84ce440f87ca7d3fe3271c2b8cfbc67d55e4de25e6fe378
|
PKG_HASH:=02ebf60a43011e770799336365bcbce2eb85569e9b5f52aa0d8cc04672438a0a
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
|
||||||
|
@ -48,7 +48,7 @@ define Package/libzmq-curve
|
||||||
$(call Package/libzmq/default)
|
$(call Package/libzmq/default)
|
||||||
VARIANT:=curve
|
VARIANT:=curve
|
||||||
TITLE+= (CurveZMQ)
|
TITLE+= (CurveZMQ)
|
||||||
DEPENDS+=+libsodium
|
DEPENDS+=+libsodium
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/libzmq-nc/description
|
define Package/libzmq-nc/description
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -148,8 +148,10 @@ case "${host_os}" in
|
@@ -150,8 +150,10 @@ case "${host_os}" in
|
||||||
*linux*)
|
*linux*)
|
||||||
# Define on Linux to enable all library features. Define if using a gnu compiler
|
# Define on Linux to enable all library features. Define if using a gnu compiler
|
||||||
if test "x$GXX" = "xyes"; then
|
if test "x$GXX" = "xyes"; then
|
||||||
|
|
|
@ -21,7 +21,7 @@
|
||||||
|
|
||||||
--- a/src/stream_engine.cpp
|
--- a/src/stream_engine.cpp
|
||||||
+++ b/src/stream_engine.cpp
|
+++ b/src/stream_engine.cpp
|
||||||
@@ -208,7 +208,7 @@ void zmq::stream_engine_t::plug (io_thre
|
@@ -208,7 +208,7 @@ void zmq::stream_engine_t::plug (io_thread_t *io_thread_,
|
||||||
// Compile metadata.
|
// Compile metadata.
|
||||||
typedef metadata_t::dict_t properties_t;
|
typedef metadata_t::dict_t properties_t;
|
||||||
properties_t properties;
|
properties_t properties;
|
||||||
|
@ -30,7 +30,7 @@
|
||||||
zmq_assert (metadata == NULL);
|
zmq_assert (metadata == NULL);
|
||||||
metadata = new (std::nothrow) metadata_t (properties);
|
metadata = new (std::nothrow) metadata_t (properties);
|
||||||
}
|
}
|
||||||
@@ -815,7 +815,7 @@ void zmq::stream_engine_t::mechanism_rea
|
@@ -815,7 +815,7 @@ void zmq::stream_engine_t::mechanism_ready ()
|
||||||
|
|
||||||
// If we have a peer_address, add it to metadata
|
// If we have a peer_address, add it to metadata
|
||||||
if (!peer_address.empty()) {
|
if (!peer_address.empty()) {
|
||||||
|
|
Loading…
Reference in a new issue