wipe: add new package
Signed-off-by: Toni Uhlig <matzeton@googlemail.com>
This commit is contained in:
parent
d3b32a62c2
commit
294fed0566
2 changed files with 72 additions and 0 deletions
42
utils/wipe/Makefile
Normal file
42
utils/wipe/Makefile
Normal file
|
@ -0,0 +1,42 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=wipe
|
||||
PKG_VERSION:=0.24
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/berke/$(PKG_NAME)/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=aefb4403333562f9af5e3e03ecbba4b124e98788c688662240f9b04d80bfdb2f
|
||||
|
||||
PKG_MAINTAINER:=Toni Uhlig <matzeton@googlemail.com>
|
||||
PKG_LICENSE:=GPL-2.0-only
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/wipe
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=securely erase files
|
||||
URL:=http://lambda-diode.com/software/wipe/
|
||||
endef
|
||||
|
||||
define Package/wipe/description
|
||||
wipe is a little command for securely erasing files from magnetic media.
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) linux \
|
||||
CC_LINUX="$(TARGET_CC)" \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
LDFLAGS="$(TARGET_LDFLAGS)" \
|
||||
CPPFLAGS="$(TARGET_CPPFLAGS)"
|
||||
endef
|
||||
|
||||
define Package/wipe/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/wipe $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,wipe))
|
|
@ -0,0 +1,30 @@
|
|||
diff --git a/Makefile b/Makefile
|
||||
index 5757ae3..20d52ce 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -157,11 +157,7 @@ wipe.o : wipe.c random.h misc.h version.h
|
||||
$(CC) $(CCO) $(CCOC) wipe.c -o wipe.o
|
||||
|
||||
version.h: always
|
||||
- if which git >/dev/null 2>&1 ; then \
|
||||
- git rev-list --max-count=1 HEAD | sed -e 's/^/#define WIPE_GIT "/' -e 's/$$/"/' >version.h ; \
|
||||
- else \
|
||||
- echo '#define WIPE_GIT "(unknown, compiled without git)"' >version.h ; \
|
||||
- fi
|
||||
+ echo '#define WIPE_GIT "(unknown, compiled without git)"' >version.h ; \
|
||||
|
||||
random.o : random.c misc.h md5.h
|
||||
$(CC) $(CCO) $(CCOC) random.c -o random.o
|
||||
diff --git a/wipe.c b/wipe.c
|
||||
index 5a215e8..5a4f2ad 100644
|
||||
--- a/wipe.c
|
||||
+++ b/wipe.c
|
||||
@@ -24,7 +24,7 @@
|
||||
|
||||
/*** defines */
|
||||
|
||||
-#define WIPE_VERSION "0.23"
|
||||
+#define WIPE_VERSION "0.24"
|
||||
#define WIPE_DATE "2016-11-03"
|
||||
|
||||
/* exit codes */
|
Loading…
Reference in a new issue