dosfstools: update to 4.2
Remove upstreamed patch. Added AUTORELEASE for simplicity. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
a30518f99e
commit
29440d1575
2 changed files with 4 additions and 28 deletions
|
@ -8,15 +8,15 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=dosfstools
|
PKG_NAME:=dosfstools
|
||||||
PKG_VERSION:=4.1
|
PKG_VERSION:=4.2
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=https://github.com/dosfstools/dosfstools/releases/download/v$(PKG_VERSION)/ \
|
PKG_SOURCE_URL:=https://github.com/dosfstools/dosfstools/releases/download/v$(PKG_VERSION)/ \
|
||||||
http://fossies.org/linux/misc
|
http://fossies.org/linux/misc
|
||||||
PKG_HASH:=e6b2aca70ccc3fe3687365009dd94a2e18e82b688ed4e260e04b7412471cc173
|
PKG_HASH:=ba7c716ff9b8208a3bba5094a77584a7dc814141de09ab4ce1ae9b84bbcd7844
|
||||||
PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
|
|
||||||
|
|
||||||
|
PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
|
||||||
PKG_LICENSE:=GPL-3.0-or-later
|
PKG_LICENSE:=GPL-3.0-or-later
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
PKG_CPE_ID:=cpe:/a:dosfstools_project:dosfstools
|
PKG_CPE_ID:=cpe:/a:dosfstools_project:dosfstools
|
||||||
|
|
|
@ -1,24 +0,0 @@
|
||||||
From e18bcc65d5772e518c6496b439bad8a986f7e434 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Rosen Penev <rosenp@gmail.com>
|
|
||||||
Date: Thu, 20 Jun 2019 15:18:19 -0700
|
|
||||||
Subject: [PATCH] configure: Fix iconv check for cross compilation
|
|
||||||
|
|
||||||
AC_CHECK_LIB is more friendly towards cross-compilation.
|
|
||||||
|
|
||||||
Added check for libiconv_open as that can be used when the libc lacks iconv.
|
|
||||||
---
|
|
||||||
configure.ac | 3 ++-
|
|
||||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -59,7 +59,8 @@ if test "x$with_udev" != "xno"; then
|
|
||||||
[true])
|
|
||||||
fi
|
|
||||||
|
|
||||||
-AC_SEARCH_LIBS(iconv_open, iconv)
|
|
||||||
+AC_CHECK_LIB(iconv, iconv_open)
|
|
||||||
+AC_CHECK_LIB(iconv, libiconv_open)
|
|
||||||
|
|
||||||
# xxd (distributed with vim) is used in the testsuite
|
|
||||||
AC_CHECK_PROG([XXD_FOUND], [xxd], [yes])
|
|
Loading…
Reference in a new issue