xfsprogs: Update to 6.2.0
* Added new dependencies introduced in this version * Disabled mips16 due to build issues * Fixed the usage of the `CONFIG_USE_MUSL` variable (missing $) * Refreshed patches Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
This commit is contained in:
parent
abfe6272cd
commit
284093d85a
2 changed files with 10 additions and 7 deletions
|
@ -8,20 +8,22 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=xfsprogs
|
PKG_NAME:=xfsprogs
|
||||||
PKG_VERSION:=5.9.0
|
PKG_VERSION:=6.2.0
|
||||||
PKG_RELEASE:=3
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@KERNEL/linux/utils/fs/xfs/xfsprogs
|
PKG_SOURCE_URL:=@KERNEL/linux/utils/fs/xfs/xfsprogs
|
||||||
PKG_HASH:=bc5c805596bc609a18dc1f1b4ed6a2821dba9f47408ec00e7799ceea1b2097f1
|
PKG_HASH:=d67dcba5a28e0904b60886b6e5f752bc7c9c3a5c7096153855b5adca9db86c51
|
||||||
|
|
||||||
PKG_MAINTAINER:=
|
PKG_MAINTAINER:=
|
||||||
PKG_LICENSE:=GPL-2.0-only
|
PKG_LICENSE:=GPL-2.0-only
|
||||||
PKG_LICENSE_FILES:=LICENSES/GPL-2.0
|
PKG_LICENSE_FILES:=LICENSES/GPL-2.0
|
||||||
PKG_CPE_ID:=cpe:/a:sgi:xfsprogs
|
PKG_CPE_ID:=cpe:/a:sgi:xfsprogs
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_BUILD_DEPENDS:=inih
|
||||||
|
PKG_BUILD_FLAGS:=no-mips16
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
@ -29,7 +31,7 @@ define Package/xfsprogs/default
|
||||||
SECTION:=utils
|
SECTION:=utils
|
||||||
CATEGORY:=Utilities
|
CATEGORY:=Utilities
|
||||||
SUBMENU:=Filesystem
|
SUBMENU:=Filesystem
|
||||||
DEPENDS:=+libuuid +libpthread
|
DEPENDS:=+liburcu +libuuid +libpthread
|
||||||
URL:=https://xfs.org/
|
URL:=https://xfs.org/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
@ -41,6 +43,7 @@ endef
|
||||||
define Package/xfs-mkfs
|
define Package/xfs-mkfs
|
||||||
$(call Package/xfsprogs/default)
|
$(call Package/xfsprogs/default)
|
||||||
TITLE:=Utility for creating XFS filesystems
|
TITLE:=Utility for creating XFS filesystems
|
||||||
|
DEPENDS+=+libinih
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/xfs-fsck
|
define Package/xfs-fsck
|
||||||
|
@ -67,7 +70,7 @@ CONFIGURE_ARGS += \
|
||||||
--disable-scrub \
|
--disable-scrub \
|
||||||
--disable-libicu
|
--disable-libicu
|
||||||
|
|
||||||
TARGET_CFLAGS += -DHAVE_MAP_SYNC $(if (CONFIG_USE_MUSL),-D_LARGEFILE64_SOURCE)
|
TARGET_CFLAGS += -DHAVE_MAP_SYNC $(if $(CONFIG_USE_MUSL),-D_LARGEFILE64_SOURCE)
|
||||||
TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
|
TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
|
||||||
|
|
||||||
define Package/xfs-admin/install
|
define Package/xfs-admin/install
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/libxfs/libxfs_priv.h
|
--- a/libxfs/libxfs_priv.h
|
||||||
+++ b/libxfs/libxfs_priv.h
|
+++ b/libxfs/libxfs_priv.h
|
||||||
@@ -87,9 +87,6 @@ struct iomap;
|
@@ -89,9 +89,6 @@ struct iomap;
|
||||||
/* for all the support code that uses progname in error messages */
|
/* for all the support code that uses progname in error messages */
|
||||||
extern char *progname;
|
extern char *progname;
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue