nfs-kernel-server: update to 2.2.1
Signed-off-by: Peter Wagner <tripolar@gmx.at>
This commit is contained in:
parent
b819714142
commit
274eb1e720
3 changed files with 15 additions and 6 deletions
|
@ -7,9 +7,9 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=nfs-kernel-server
|
||||
PKG_VERSION:=2.1.1
|
||||
PKG_VERSION:=2.2.1
|
||||
PKG_RELEASE:=1
|
||||
PKG_HASH:=0a28416948516c26f3bfe90425b0de09b79364dc1f508bf1dda8de66e1edbb09
|
||||
PKG_HASH:=0d819d8da358bea6e005e1a6cf0f6fa0c5507a78747d36bc87a0182e6af14291
|
||||
|
||||
PKG_SOURCE_URL:=@SF/nfs
|
||||
PKG_SOURCE:=nfs-utils-$(PKG_VERSION).tar.bz2
|
||||
|
@ -86,6 +86,7 @@ CONFIGURE_ARGS += \
|
|||
|
||||
CONFIGURE_VARS += \
|
||||
libblkid_cv_is_recent=yes \
|
||||
ac_cv_lib_resolv___res_querydomain=yes \
|
||||
CONFIG_SQLITE3_TRUE="\#" \
|
||||
CONFIG_NFSDCLD_TRUE="\#"
|
||||
|
||||
|
|
|
@ -1,11 +1,9 @@
|
|||
Musl will always return something with getservbyport so we cannot skip
|
||||
ports that returns non-null.
|
||||
|
||||
diff --git a/utils/statd/rmtcall.c b/utils/statd/rmtcall.c
|
||||
index fd576d9..d72a0bf 100644
|
||||
--- a/utils/statd/rmtcall.c
|
||||
+++ b/utils/statd/rmtcall.c
|
||||
@@ -90,8 +90,10 @@ statd_get_socket(void)
|
||||
@@ -93,8 +93,10 @@ statd_get_socket(void)
|
||||
__func__);
|
||||
break;
|
||||
}
|
||||
|
@ -14,5 +12,5 @@ index fd576d9..d72a0bf 100644
|
|||
if (se == NULL)
|
||||
+#endif
|
||||
break;
|
||||
/* rather not use that port, try again */
|
||||
|
||||
if (retries == MAX_BRP_RETRIES) {
|
||||
|
|
10
net/nfs-kernel-server/patches/102-limits.patch
Normal file
10
net/nfs-kernel-server/patches/102-limits.patch
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- a/support/misc/file.c
|
||||
+++ b/support/misc/file.c
|
||||
@@ -27,6 +27,7 @@
|
||||
#include <dirent.h>
|
||||
#include <stdlib.h>
|
||||
#include <stdbool.h>
|
||||
+#include <limits.h>
|
||||
|
||||
#include "xlog.h"
|
||||
#include "misc.h"
|
Loading…
Reference in a new issue