python-cryptography: fix build by disabling setup requirements
python-cryptography tries to install other packages during setup. However, this isn't needed, since they should have been already resolved/installed via LEDE/OpenWrt's build system dep logic. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
This commit is contained in:
parent
4bceecac96
commit
274cacf365
2 changed files with 13 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=cryptography
|
||||
PKG_VERSION:=1.5.1
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://pypi.python.org/packages/21/e1/37fc14f9d77924e84ba0dcb88eb8352db914583af229287c6c965d66ba0d
|
||||
|
|
|
@ -0,0 +1,12 @@
|
|||
diff --git a/setup.py b/setup.py
|
||||
index b5c05df..a777dd7 100644
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -266,6 +266,7 @@ class DummyPyTest(test):
|
||||
with open(os.path.join(base_dir, "README.rst")) as f:
|
||||
long_description = f.read()
|
||||
|
||||
+setup_requirements=[]
|
||||
|
||||
setup(
|
||||
name=about["__title__"],
|
Loading…
Reference in a new issue