Upgrade socat to 1.7.3.0.
The cross-compiling patch is no longer necessary. Also added librt as a dependency, since it is required. This also fixes an issue where support for linux/errqueue.h was not being detected correctly and causing a build failure with 3.18. Signed-off-by: John Szakmeister <john@szakmeister.net>
This commit is contained in:
parent
861f57e924
commit
2720fe57e5
2 changed files with 4 additions and 26 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=socat
|
||||
PKG_VERSION:=1.7.2.4
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=1.7.3.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://www.dest-unreach.org/socat/download
|
||||
PKG_MD5SUM:=69b8155dd442a6f24e28ef5407d868eb
|
||||
PKG_MD5SUM:=b607edb65bc6c57f4a43f06247504274
|
||||
|
||||
PKG_MAINTAINER:= Ted Hess <thess@kitschensync.net>
|
||||
|
||||
|
@ -27,7 +27,7 @@ include $(INCLUDE_DIR)/package.mk
|
|||
define Package/socat
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+libpthread +SOCAT_SSL:libopenssl
|
||||
DEPENDS:=+libpthread +librt +SOCAT_SSL:libopenssl
|
||||
TITLE:=A multipurpose relay (SOcket CAT)
|
||||
URL:=http://www.dest-unreach.org/socat/
|
||||
endef
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -41,7 +41,7 @@ AC_CHECK_PROG(AR, ar, ar, gar)
|
||||
# fail
|
||||
AC_LANG_COMPILER_REQUIRE()
|
||||
|
||||
-if test "$CC" = "gcc"; then
|
||||
+if test "$GCC" = yes; then
|
||||
CFLAGS="$CFLAGS -D_GNU_SOURCE -Wall -Wno-parentheses"
|
||||
ERRONWARN="-Werror -O0"
|
||||
elif test "$CC" = "clang"; then
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -3348,7 +3348,7 @@ fi
|
||||
|
||||
|
||||
|
||||
-if test "$CC" = "gcc"; then
|
||||
+if test "$GCC" = yes; then
|
||||
CFLAGS="$CFLAGS -D_GNU_SOURCE -Wall -Wno-parentheses"
|
||||
ERRONWARN="-Werror -O0"
|
||||
elif test "$CC" = "clang"; then
|
Loading…
Reference in a new issue