frr: update to 8.3.0
Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
This commit is contained in:
parent
7017211091
commit
26b64bee70
3 changed files with 9 additions and 9 deletions
|
@ -7,16 +7,16 @@
|
|||
|
||||
include $(TOPDIR)/rules.mk
|
||||
PKG_NAME:=frr
|
||||
PKG_VERSION:=8.2.2
|
||||
PKG_VERSION:=8.3.0
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
PKG_SOURCE_DATE:=2022-03-22
|
||||
PKG_SOURCE_DATE:=2022-07-27
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_DATE).tar.gz
|
||||
PKG_SOURCE_VERSION:=830ba8bb25fb9968a4cd331a60344ad53ea0e300
|
||||
PKG_SOURCE_VERSION:=4a27375c965a7d9079b7aba1555df54df47f1ca4
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/FRRouting/frr/tar.gz/$(PKG_SOURCE_VERSION)?
|
||||
|
||||
|
||||
PKG_HASH:=bf75b6443c65937d1b2713e75359c0d1e0f02c049c9ab5c7b9af4a0ce05f5700
|
||||
PKG_HASH:=d09fd6517b955f37418f0d260d0cd5fda0b3f4fd416e3121f270ce3934cdf6ba
|
||||
PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_SOURCE_VERSION)
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -816,7 +816,6 @@ fi
|
||||
@@ -833,7 +833,6 @@ fi
|
||||
#
|
||||
|
||||
AS_IF([test "$host" = "$build"], [
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/lib/thread.c
|
||||
+++ b/lib/thread.c
|
||||
@@ -830,13 +830,9 @@ static void thread_free(struct thread_ma
|
||||
@@ -867,13 +867,9 @@ static void thread_free(struct thread_ma
|
||||
XFREE(MTYPE_THREAD, thread);
|
||||
}
|
||||
|
||||
|
@ -16,7 +16,7 @@
|
|||
/*
|
||||
* If timer_wait is null here, that means poll() should block
|
||||
* indefinitely, unless the thread_master has overridden it by setting
|
||||
@@ -867,58 +863,15 @@ static int fd_poll(struct thread_master
|
||||
@@ -904,58 +900,15 @@ static int fd_poll(struct thread_master
|
||||
rcu_assert_read_unlocked();
|
||||
|
||||
/* add poll pipe poker */
|
||||
|
@ -82,7 +82,7 @@
|
|||
while (read(m->io_pipe[0], &trash, sizeof(trash)) > 0)
|
||||
;
|
||||
|
||||
@@ -1718,7 +1671,7 @@ struct thread *thread_fetch(struct threa
|
||||
@@ -1762,7 +1715,7 @@ struct thread *thread_fetch(struct threa
|
||||
struct timeval zerotime = {0, 0};
|
||||
struct timeval tv;
|
||||
struct timeval *tw = NULL;
|
||||
|
@ -91,7 +91,7 @@
|
|||
int num = 0;
|
||||
|
||||
do {
|
||||
@@ -1794,14 +1747,14 @@ struct thread *thread_fetch(struct threa
|
||||
@@ -1838,14 +1791,14 @@ struct thread *thread_fetch(struct threa
|
||||
|
||||
pthread_mutex_unlock(&m->mtx);
|
||||
{
|
||||
|
|
Loading…
Reference in a new issue