diff --git a/libs/libopusenc/Makefile b/libs/libopusenc/Makefile
new file mode 100644
index 000000000..3f0dba57d
--- /dev/null
+++ b/libs/libopusenc/Makefile
@@ -0,0 +1,51 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libopusenc
+PKG_VERSION:=0.2.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://archive.mozilla.org/pub/opus
+PKG_HASH:=8298db61a8d3d63e41c1a80705baa8ce9ff3f50452ea7ec1c19a564fe106cbb9
+
+PKG_MAINTAINER:=Eduardo Abinader <eduardoabinader@gmail.com>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=COPYING
+
+PKG_BUILD_PARALLEL:=1
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libopusenc
+  SECTION:=libs
+  CATEGORY:=Libraries
+  DEPENDS:=+libopus
+  TITLE:=OPUS Audio stream files
+  URL:=https://opus-codec.org
+endef
+
+define Package/libopusenc/descriptiion
+ Libopusenc provides a high-level API for creating .opus files and streams.
+endef
+
+define Build/InstallDev
+	$(INSTALL_DIR) $(1)/usr/include
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+	$(INSTALL_DIR) $(1)/usr/lib
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libopusenc.pc $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libopusenc/install
+	$(INSTALL_DIR) $(1)/usr/lib
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libopusenc))
diff --git a/libs/opusfile/Makefile b/libs/opusfile/Makefile
new file mode 100644
index 000000000..eb8475c96
--- /dev/null
+++ b/libs/opusfile/Makefile
@@ -0,0 +1,54 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=opusfile
+PKG_VERSION:=0.11
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://downloads.xiph.org/releases/opus/
+PKG_HASH:=74ce9b6cf4da103133e7b5c95df810ceb7195471e1162ed57af415fabf5603bf
+
+PKG_LICENSE:=BSD-2-Clause
+PKG_LICENSE_FILES:=COPYING
+PKG_MAINTAINER:=Eduardo Abinader <eduardoabinader@gmail.com>
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libopusfile
+   SECTION:=libs
+   CATEGORY:=Libraries
+   DEPENDS:=+libogg +libopus +libopenssl
+   TITLE:=OPUS file library
+   URL:=http://opus-codec.org/
+endef
+
+define Package/libopusfile/description
+ The opusfile library provides seeking, decode, and playback of Opus streams in the Ogg container (.opus files)
+endef
+
+CONFIGURE_ARGS += \
+	--without-flac \
+
+define Build/InstallDev
+	$(INSTALL_DIR) $(1)/usr/include
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+	$(INSTALL_DIR) $(1)/usr/lib
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/opusfile.pc $(1)/usr/lib/pkgconfig/
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/opusurl.pc $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libopusfile/install
+	$(INSTALL_DIR) $(1)/usr/lib
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libopusfile))
diff --git a/sound/opus-tools/Makefile b/sound/opus-tools/Makefile
index 1b5b9a106..4e4d0b638 100644
--- a/sound/opus-tools/Makefile
+++ b/sound/opus-tools/Makefile
@@ -6,17 +6,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=opus-tools
-PKG_VERSION:=0.1.10
+PKG_VERSION:=0.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.xiph.org/releases/opus/
-PKG_HASH:=a2357532d19471b70666e0e0ec17d514246d8b3cb2eb168f68bb0f6fd372b28c
+PKG_HASH:=b4e56cb00d3e509acfba9a9b627ffd8273b876b4e2408642259f6da28fa0ff86
 
 PKG_LICENSE:=BSD-2-Clause
 PKG_LICENSE_FILES:=COPYING
-PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>, \
-		Nicolas Thill <nico@openwrt.org>
+PKG_MAINTAINER:=Eduardo Abinader <eduardoabinader@gmail.com>
 
 PKG_INSTALL:=1
 
@@ -25,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/opus-tools
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+libogg +libopus
+  DEPENDS:=+libogg +libopus +libopusfile +libopusenc
   TITLE:=OPUS Codec tools
   URL:=http://opus-codec.org/
 endef