lang/perl-www-curl: Update 100-perl-www-curl_disable_curl-config_hack.patch
Signed-off-by: Marcel Denia <naoir@gmx.net>
This commit is contained in:
parent
7585f8f9d2
commit
2613af4b1d
1 changed files with 71 additions and 8 deletions
|
@ -1,11 +1,74 @@
|
|||
--- WWW-Curl-4.00.config/Makefile.PL 2008-04-21 23:18:39.000000000 +0200
|
||||
+++ WWW-Curl-4.00/Makefile.PL 2008-04-21 23:18:52.000000000 +0200
|
||||
@@ -11,7 +11,7 @@
|
||||
no_index directory => 'template';
|
||||
--- a/Makefile.PL
|
||||
+++ b/Makefile.PL
|
||||
@@ -12,31 +12,31 @@ no_index directory => 'template';
|
||||
repository 'http://github.com/szbalint/WWW--Curl';
|
||||
# This is a hack. If you have libcurl installed, just specify curl.h below
|
||||
# and comment out this line.
|
||||
-requires_external_bin 'curl-config';
|
||||
+#requires_external_bin 'curl-config';
|
||||
-if ($^O ne 'MSWin32') {
|
||||
- if (!$ENV{CURL_CONFIG}) {
|
||||
- requires_external_bin 'curl-config';
|
||||
- }
|
||||
-} else {
|
||||
- print "Sorry, no automated install is available on Windows,\n".
|
||||
- "please see the README.Win32 file on instructions for a manual install.\n";
|
||||
- exit(0);
|
||||
-}
|
||||
-
|
||||
-my $curl_config = $ENV{CURL_CONFIG} || 'curl-config';
|
||||
-
|
||||
-my $vernum = `${curl_config} --vernum`; chomp $vernum;
|
||||
-my $version = `${curl_config} --version`; chomp $version;
|
||||
-
|
||||
-my $minimum_ver = hex("070a08");
|
||||
-
|
||||
-if ($vernum && hex($vernum) <= $minimum_ver) {
|
||||
- print "Your currently installed libcurl version - $version - is too old.\n".
|
||||
- "This module doesn't seek compatibility with versions older than 7.10.8\n".
|
||||
- "Proceed manually if you know what you're doing.\n";
|
||||
- exit(0);
|
||||
-}
|
||||
-
|
||||
-print "The version is $version\n";
|
||||
+#if ($^O ne 'MSWin32') {
|
||||
+# if (!$ENV{CURL_CONFIG}) {
|
||||
+# requires_external_bin 'curl-config';
|
||||
+# }
|
||||
+#} else {
|
||||
+# print "Sorry, no automated install is available on Windows,\n".
|
||||
+# "please see the README.Win32 file on instructions for a manual install.\n";
|
||||
+# exit(0);
|
||||
+#}
|
||||
+#
|
||||
+#my $curl_config = $ENV{CURL_CONFIG} || 'curl-config';
|
||||
+#
|
||||
+#my $vernum = `${curl_config} --vernum`; chomp $vernum;
|
||||
+#my $version = `${curl_config} --version`; chomp $version;
|
||||
+#
|
||||
+#my $minimum_ver = hex("070a08");
|
||||
+#
|
||||
+#if ($vernum && hex($vernum) <= $minimum_ver) {
|
||||
+# print "Your currently installed libcurl version - $version - is too old.\n".
|
||||
+# "This module doesn't seek compatibility with versions older than 7.10.8\n".
|
||||
+# "Proceed manually if you know what you're doing.\n";
|
||||
+# exit(0);
|
||||
+#}
|
||||
+#
|
||||
+#print "The version is $version\n";
|
||||
|
||||
# This utility helper generates the constants function from curl.h
|
||||
# It is normally only used by the maintainer, but if you're curl is older
|
||||
my @includes = qw();
|
||||
my ($cflags,$lflags, $ldflags) = ('','','');
|
||||
@@ -58,10 +58,10 @@ if ($^O ne 'MSWin32') {
|
||||
# Get curl to tell us where it is, if we can.
|
||||
#
|
||||
|
||||
-if ($^O ne 'MSWin32') {
|
||||
- $cflags = `${curl_config} --cflags`;
|
||||
- $lflags = `${curl_config} --libs`;
|
||||
-}
|
||||
+#if ($^O ne 'MSWin32') {
|
||||
+# $cflags = `${curl_config} --cflags`;
|
||||
+# $lflags = `${curl_config} --libs`;
|
||||
+#}
|
||||
|
||||
# can't find link flags, make some guesses
|
||||
if (!defined($lflags)) {
|
||||
|
|
Loading…
Reference in a new issue