lvm2: update sources and improve packaging
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
This commit is contained in:
parent
7b6e938790
commit
25660aad62
2 changed files with 14 additions and 10 deletions
|
@ -9,13 +9,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=LVM2
|
||||
PKG_VERSION:=2.02.122
|
||||
PKG_VERSION:=2.02.124
|
||||
PKG_RELEASE:=1
|
||||
PKG_LICENSE:=GPL-2.0 LGPL-2.1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
|
||||
PKG_SOURCE_URL:=ftp://sources.redhat.com/pub/lvm2
|
||||
PKG_MD5SUM:=a88bf7d68955635d009a5aec1ffecc48
|
||||
PKG_MD5SUM:=da8d81a6a2ea235025795d9e001a6ae3
|
||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME).$(PKG_VERSION)
|
||||
|
||||
|
@ -74,10 +74,14 @@ endef
|
|||
|
||||
define Package/lvm2/install
|
||||
$(INSTALL_DIR) $(1)/sbin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/tools/lvm $(1)/sbin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/lvm $(1)/sbin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dmsetup $(1)/sbin
|
||||
$(INSTALL_DIR) $(1)/etc/lvm
|
||||
$(SED) '/^[[:space:]]*\(#\|$$$$\)/d; /cache_dir/s@.*@ cache_dir = "/tmp/lvm/cache"@' $(PKG_BUILD_DIR)/conf/example.conf
|
||||
$(INSTALL_CONF) $(PKG_BUILD_DIR)/conf/example.conf $(1)/etc/lvm/lvm.conf
|
||||
$(SED) '/^[[:space:]]*\(#\|$$$$\)/d; /cache_dir/s@.*@ cache_dir = "/tmp/lvm/cache"@' $(PKG_INSTALL_DIR)/etc/lvm/lvm.conf
|
||||
$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/lvm/lvm.conf $(1)/etc/lvm/
|
||||
$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/lvm/lvmlocal.conf $(1)/etc/lvm/
|
||||
$(INSTALL_DIR) $(1)/etc/lvm/profile
|
||||
$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/lvm/profile/* $(1)/etc/lvm/profile/
|
||||
$(INSTALL_DIR) $(1)/etc/init.d
|
||||
$(INSTALL_BIN) ./files/lvm2.init $(1)/etc/init.d/lvm2
|
||||
$(FIND) $(PKG_INSTALL_DIR)/usr/sbin/ -type l -exec $(CP) -a {} $(1)/sbin/ \;
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/lib/commands/toolcontext.c
|
||||
+++ b/lib/commands/toolcontext.c
|
||||
@@ -1637,8 +1637,10 @@ struct cmd_context *create_toolcontext(u
|
||||
@@ -1690,8 +1690,10 @@ struct cmd_context *create_toolcontext(u
|
||||
unsigned threaded)
|
||||
{
|
||||
struct cmd_context *cmd;
|
||||
|
@ -11,7 +11,7 @@
|
|||
|
||||
#ifdef M_MMAP_MAX
|
||||
mallopt(M_MMAP_MAX, 0);
|
||||
@@ -1674,7 +1676,7 @@ struct cmd_context *create_toolcontext(u
|
||||
@@ -1727,7 +1729,7 @@ struct cmd_context *create_toolcontext(u
|
||||
/* FIXME Make this configurable? */
|
||||
reset_lvm_errno(1);
|
||||
|
||||
|
@ -20,7 +20,7 @@
|
|||
/* Set in/out stream buffering before glibc */
|
||||
if (set_buffering) {
|
||||
/* Allocate 2 buffers */
|
||||
@@ -2047,7 +2049,7 @@ void destroy_toolcontext(struct cmd_cont
|
||||
@@ -2100,7 +2102,7 @@ void destroy_toolcontext(struct cmd_cont
|
||||
if (cmd->libmem)
|
||||
dm_pool_destroy(cmd->libmem);
|
||||
|
||||
|
@ -31,7 +31,7 @@
|
|||
if (is_valid_fd(STDIN_FILENO) &&
|
||||
--- a/tools/lvmcmdline.c
|
||||
+++ b/tools/lvmcmdline.c
|
||||
@@ -1635,6 +1635,7 @@ int lvm_split(char *str, int *argc, char
|
||||
@@ -1688,6 +1688,7 @@ int lvm_split(char *str, int *argc, char
|
||||
/* Make sure we have always valid filedescriptors 0,1,2 */
|
||||
static int _check_standard_fds(void)
|
||||
{
|
||||
|
@ -39,7 +39,7 @@
|
|||
int err = is_valid_fd(STDERR_FILENO);
|
||||
|
||||
if (!is_valid_fd(STDIN_FILENO) &&
|
||||
@@ -1661,6 +1662,12 @@ static int _check_standard_fds(void)
|
||||
@@ -1714,6 +1715,12 @@ static int _check_standard_fds(void)
|
||||
strerror(errno));
|
||||
return 0;
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue