Merge pull request #12469 from neheb/zst
zstd: fix compilation without host distutils
This commit is contained in:
commit
24c822d746
2 changed files with 22 additions and 1 deletions
|
@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=zstd
|
PKG_NAME:=zstd
|
||||||
PKG_VERSION:=1.4.5
|
PKG_VERSION:=1.4.5
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.zst
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.zst
|
||||||
PKG_SOURCE_URL:=https://github.com/facebook/zstd/releases/download/v$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://github.com/facebook/zstd/releases/download/v$(PKG_VERSION)
|
||||||
|
|
21
utils/zstd/patches/010-python.patch
Normal file
21
utils/zstd/patches/010-python.patch
Normal file
|
@ -0,0 +1,21 @@
|
||||||
|
--- a/build/meson/meson.build
|
||||||
|
+++ b/build/meson/meson.build
|
||||||
|
@@ -22,7 +22,6 @@ project('zstd',
|
||||||
|
cc = meson.get_compiler('c')
|
||||||
|
cxx = meson.get_compiler('cpp')
|
||||||
|
pkgconfig = import('pkgconfig')
|
||||||
|
-python3 = import('python').find_installation()
|
||||||
|
windows_mod = import('windows')
|
||||||
|
|
||||||
|
host_machine_os = host_machine.system()
|
||||||
|
@@ -40,8 +39,8 @@ compiler_msvc = 'msvc'
|
||||||
|
zstd_version = meson.project_version()
|
||||||
|
|
||||||
|
zstd_h_file = join_paths(meson.current_source_dir(), '../../lib/zstd.h')
|
||||||
|
-GetZstdLibraryVersion_py = files('GetZstdLibraryVersion.py')
|
||||||
|
-r = run_command(python3, GetZstdLibraryVersion_py, zstd_h_file)
|
||||||
|
+GetZstdLibraryVersion_py = find_program('GetZstdLibraryVersion.py', native : true)
|
||||||
|
+r = run_command(GetZstdLibraryVersion_py, zstd_h_file)
|
||||||
|
if r.returncode() == 0
|
||||||
|
zstd_version = r.stdout().strip()
|
||||||
|
message('Project version is now: @0@'.format(zstd_version))
|
Loading…
Reference in a new issue