commit
24487afe1f
3 changed files with 5 additions and 36 deletions
|
@ -8,15 +8,15 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=curl
|
PKG_NAME:=curl
|
||||||
PKG_VERSION:=7.72.0
|
PKG_VERSION:=7.73.0
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
|
PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
|
||||||
https://curl.mirror.anstey.ca/ \
|
https://curl.mirror.anstey.ca/ \
|
||||||
https://curl.askapache.com/download/ \
|
https://curl.askapache.com/download/ \
|
||||||
https://curl.haxx.se/download/
|
https://curl.haxx.se/download/
|
||||||
PKG_HASH:=0ded0808c4d85f2ee0db86980ae610cc9d165e9ca9da466196cc73c346513713
|
PKG_HASH:=7c4c7ca4ea88abe00fea4740dcf81075c031b1d0bb23aff2d5efde20a3c2408a
|
||||||
|
|
||||||
PKG_LICENSE:=MIT
|
PKG_LICENSE:=MIT
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
|
@ -1,31 +0,0 @@
|
||||||
From 510d98157f21dee5793c4e975fde3317b6139267 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Daniel Stenberg <daniel@haxx.se>
|
|
||||||
Date: Mon, 24 Aug 2020 16:28:34 +0200
|
|
||||||
Subject: [PATCH] configure: fix pkg-config detecting wolfssl
|
|
||||||
|
|
||||||
When amending the include path with "/wolfssl", this now properly strips
|
|
||||||
off all whitespace from the path variable! Previously this would lead to
|
|
||||||
pkg-config builds creating bad command lines.
|
|
||||||
|
|
||||||
Closes #5848
|
|
||||||
---
|
|
||||||
configure.ac | 8 ++++++--
|
|
||||||
1 file changed, 6 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -2474,8 +2474,12 @@ if test -z "$ssl_backends" -o "x$OPT_WOL
|
|
||||||
AC_DEFINE(HAVE_WOLFSSL_DES_ECB_ENCRYPT, 1,
|
|
||||||
[if you have wolfSSL_DES_ecb_encrypt])
|
|
||||||
if test -n "$addcflags"; then
|
|
||||||
- CPPFLAGS="$addcflags/wolfssl $CPPFLAGS"
|
|
||||||
- AC_MSG_NOTICE([Add $addcflags/wolfssl to CPPFLAGS])
|
|
||||||
+ dnl use a for loop to strip off whitespace
|
|
||||||
+ for f in $addcflags; do
|
|
||||||
+ CPPFLAGS="$f/wolfssl $CPPFLAGS"
|
|
||||||
+ AC_MSG_NOTICE([Add $f/wolfssl to CPPFLAGS])
|
|
||||||
+ break
|
|
||||||
+ done
|
|
||||||
else
|
|
||||||
dnl user didn't give a path, so guess/hope they installed wolfssl
|
|
||||||
dnl headers to system default location
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/Makefile.am
|
--- a/Makefile.am
|
||||||
+++ b/Makefile.am
|
+++ b/Makefile.am
|
||||||
@@ -192,7 +192,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
|
@@ -195,7 +195,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
|
||||||
bin_SCRIPTS = curl-config
|
bin_SCRIPTS = curl-config
|
||||||
|
|
||||||
SUBDIRS = lib src
|
SUBDIRS = lib src
|
||||||
|
@ -9,7 +9,7 @@
|
||||||
|
|
||||||
pkgconfigdir = $(libdir)/pkgconfig
|
pkgconfigdir = $(libdir)/pkgconfig
|
||||||
pkgconfig_DATA = libcurl.pc
|
pkgconfig_DATA = libcurl.pc
|
||||||
@@ -303,8 +303,8 @@ cygwinbin:
|
@@ -306,8 +306,8 @@ cygwinbin:
|
||||||
# We extend the standard install with a custom hook:
|
# We extend the standard install with a custom hook:
|
||||||
install-data-hook:
|
install-data-hook:
|
||||||
(cd include && $(MAKE) install)
|
(cd include && $(MAKE) install)
|
||||||
|
|
Loading…
Reference in a new issue