Merge pull request #18883 from jefferyto/python-cryptography-fix-build

python-cryptography: Fix failing build
This commit is contained in:
Alexandru Ardelean 2022-07-07 15:49:50 +03:00 committed by GitHub
commit 23eb031777
No known key found for this signature in database
GPG key ID: 4AEE18F83AFDEB23
2 changed files with 6 additions and 3 deletions

View file

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-cryptography
PKG_VERSION:=3.4.8
PKG_RELEASE:=1
PKG_RELEASE:=2
PYPI_NAME:=cryptography
PKG_HASH:=94cc5ed4ceaefcbe5bf38c8fba6a21fc1d365bb8fb826ea1688e3370b2e24a1c

View file

@ -9,9 +9,12 @@
except ImportError:
print(
"""
@@ -45,7 +45,7 @@ setuptools_rust = "setuptools-rust>=0.11
@@ -43,9 +43,9 @@ with open(os.path.join(src_dir, "cryptog
# `pyproject.toml`
setuptools_rust = "setuptools-rust>=0.11.4"
install_requirements = ["cffi>=1.12"]
setup_requirements = install_requirements + [setuptools_rust]
-setup_requirements = install_requirements + [setuptools_rust]
+setup_requirements = install_requirements
-if os.environ.get("CRYPTOGRAPHY_DONT_BUILD_RUST"):
+if True: