Merge pull request #8727 from jefferyto/python-twisted-19.2.0
python-twisted: Update to 19.2.0, refresh patches
This commit is contained in:
commit
23dcc72935
3 changed files with 10 additions and 10 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=python-twisted
|
||||
PKG_VERSION:=18.9.0
|
||||
PKG_RELEASE:=4
|
||||
PKG_VERSION:=19.2.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=Twisted-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/T/Twisted
|
||||
PKG_HASH:=294be2c6bf84ae776df2fc98e7af7d6537e1c5e60a46d33c3ce2a197677da395
|
||||
PKG_HASH:=1708e1928ae84ec9d3ebab0d427e20e1e38ff721b15bbced476d047d4a43abbe
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-twisted-$(PKG_VERSION)
|
||||
PKG_BUILD_DEPENDS:=libtirpc
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/src/twisted/python/_setup.py
|
||||
+++ b/src/twisted/python/_setup.py
|
||||
@@ -144,7 +144,6 @@ _CONSOLE_SCRIPTS = [
|
||||
@@ -147,7 +147,6 @@ _CONSOLE_SCRIPTS = [
|
||||
"conch = twisted.conch.scripts.conch:run",
|
||||
"mailmail = twisted.mail.scripts.mailmail:run",
|
||||
"pyhtmlizer = twisted.scripts.htmlizer:run",
|
||||
|
|
|
@ -1,18 +1,18 @@
|
|||
--- a/src/twisted/python/_setup.py
|
||||
+++ b/src/twisted/python/_setup.py
|
||||
@@ -169,11 +169,6 @@ class ConditionalExtension(Extension, object):
|
||||
|
||||
@@ -173,11 +173,6 @@ class ConditionalExtension(Extension, ob
|
||||
# The C extensions used for Twisted.
|
||||
_EXTENSIONS = [
|
||||
- ConditionalExtension(
|
||||
ConditionalExtension(
|
||||
- "twisted.test.raiser",
|
||||
- sources=["src/twisted/test/raiser.c"],
|
||||
- condition=lambda _: _isCPython),
|
||||
-
|
||||
ConditionalExtension(
|
||||
- ConditionalExtension(
|
||||
"twisted.internet.iocpreactor.iocpsupport",
|
||||
sources=[
|
||||
@@ -238,12 +233,11 @@ def getSetupArgs(extensions=_EXTENSIONS):
|
||||
"src/twisted/internet/iocpreactor/iocpsupport/iocpsupport.c",
|
||||
@@ -241,12 +236,11 @@ def getSetupArgs(extensions=_EXTENSIONS)
|
||||
"incremental >= 16.10.1",
|
||||
"Automat >= 0.3.0",
|
||||
"hyperlink >= 17.1.1",
|
||||
|
@ -26,7 +26,7 @@
|
|||
use_incremental=True,
|
||||
setup_requires=["incremental >= 16.10.1"],
|
||||
install_requires=requirements,
|
||||
@@ -253,7 +247,7 @@ def getSetupArgs(extensions=_EXTENSIONS):
|
||||
@@ -256,7 +250,7 @@ def getSetupArgs(extensions=_EXTENSIONS)
|
||||
cmdclass=command_classes,
|
||||
include_package_data=True,
|
||||
exclude_package_data={
|
||||
|
|
Loading…
Reference in a new issue