django-picklefield: Update to 2.1.1
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
This commit is contained in:
parent
ec8c7a8940
commit
22b4000d33
2 changed files with 27 additions and 3 deletions
|
@ -8,11 +8,11 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=django-picklefield
|
||||
PKG_VERSION:=1.1.0
|
||||
PKG_RELEASE:=5
|
||||
PKG_VERSION:=2.1.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PYPI_NAME:=$(PKG_NAME)
|
||||
PKG_HASH:=ce7fee5c6558fe5dc8924993d994ccde75bb75b91cd82787cbd4c92b95a69f9c
|
||||
PKG_HASH:=67a5e156343e3b032cac2f65565f0faa81635a99c7da74b0f07a0f5db467b646
|
||||
|
||||
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
|
||||
PKG_LICENSE:=MIT
|
||||
|
@ -23,6 +23,11 @@ include $(INCLUDE_DIR)/package.mk
|
|||
include ../python-package.mk
|
||||
include ../python3-package.mk
|
||||
|
||||
PYTHON_PKG_SETUP_VARS:= \
|
||||
PKG_VERSION="$(PKG_VERSION)"
|
||||
PYTHON3_PKG_SETUP_VARS:= \
|
||||
PKG_VERSION="$(PKG_VERSION)"
|
||||
|
||||
define Package/django-picklefield/Default
|
||||
SUBMENU:=Python
|
||||
SECTION:=lang
|
||||
|
|
|
@ -0,0 +1,19 @@
|
|||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -2,14 +2,14 @@ from __future__ import unicode_literals
|
||||
|
||||
from setuptools import find_packages, setup
|
||||
|
||||
-import picklefield
|
||||
+import os
|
||||
|
||||
with open('README.rst') as file_:
|
||||
long_description = file_.read()
|
||||
|
||||
setup(
|
||||
name='django-picklefield',
|
||||
- version=picklefield.__version__,
|
||||
+ version=os.getenv('PKG_VERSION'),
|
||||
description='Pickled object field for Django',
|
||||
long_description=long_description,
|
||||
author='Simon Charette',
|
Loading…
Reference in a new issue