libgd: fix version in generated pkg-config .pc file

With the previous change to cmake, the generated pkg-config .pc
file does not contain the library version anymore. This breaks
programs which checks for a specific version, e.g. upcoming PHP 7.4.

The version is not filled because of a variable misnaming,
which was not covered by the imported upstream patch.

To not mangle the upstream patch, add an additional patch to
fix things up.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
This commit is contained in:
Michael Heimpold 2019-12-03 21:35:43 +01:00
parent 87b21390ba
commit 2065eb8147
2 changed files with 12 additions and 1 deletions

View file

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libgd
PKG_VERSION:=2.2.5
PKG_RELEASE:=4
PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/$(PKG_NAME)/$(PKG_NAME)/releases/download/gd-$(PKG_VERSION)/

View file

@ -0,0 +1,11 @@
--- a/config/gdlib.pc.cmake
+++ b/config/gdlib.pc.cmake
@@ -5,7 +5,7 @@ includedir=${prefix}/@CMAKE_INSTALL_INCL
Name: gd
Description: GD graphics library
-Version: @GDLIB_VERSION@
+Version: @GD_VERSION@
Cflags: -I${includedir}
Libs.private: @LIBGD_DEP_LIBS@
Libs: -L${libdir} -lgd