zabbix: Fix compilation with uClibc-ng
This is similar to a patch that was previously carried.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry picked from commit 8bc32479ea
)
This commit is contained in:
parent
403c981699
commit
2058e86fad
2 changed files with 24 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=zabbix
|
||||
PKG_VERSION:=4.0.16
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/zabbix
|
||||
|
|
23
admin/zabbix/patches/120-uclibc-res.patch
Normal file
23
admin/zabbix/patches/120-uclibc-res.patch
Normal file
|
@ -0,0 +1,23 @@
|
|||
--- a/src/libs/zbxsysinfo/common/net.c
|
||||
+++ b/src/libs/zbxsysinfo/common/net.c
|
||||
@@ -547,7 +547,7 @@ static int dns_query(AGENT_REQUEST *request, AGENT_RESULT *result, int short_ans
|
||||
return SYSINFO_RET_FAIL;
|
||||
}
|
||||
|
||||
-#if defined(HAVE_RES_NINIT) && !defined(_AIX)
|
||||
+#if defined(HAVE_RES_NINIT) && !defined(_AIX) && !defined(__UCLIBC__)
|
||||
if (-1 == (res = res_nmkquery(&res_state_local, QUERY, zone, C_IN, type, NULL, 0, NULL, buf, sizeof(buf))))
|
||||
#else
|
||||
if (-1 == (res = res_mkquery(QUERY, zone, C_IN, type, NULL, 0, NULL, buf, sizeof(buf))))
|
||||
@@ -643,7 +643,11 @@ static int dns_query(AGENT_REQUEST *request, AGENT_RESULT *result, int short_ans
|
||||
res_state_local.retrans = retrans;
|
||||
res_state_local.retry = retry;
|
||||
|
||||
+#ifndef __UCLIBC__
|
||||
res = res_nsend(&res_state_local, buf, res, answer.buffer, sizeof(answer.buffer));
|
||||
+#else
|
||||
+ res = res_search(*res_state_local.dnsrch, res, 0, answer.buffer, sizeof(answer.buffer));
|
||||
+#endif
|
||||
|
||||
# ifdef HAVE_RES_U_EXT /* Linux */
|
||||
if (NULL != ip && '\0' != *ip && AF_INET6 == ip_type)
|
Loading…
Reference in a new issue