libmpdclient: Update to 2.10
Signed-off-by: Ted Hess <thess@kitschensync.net>
This commit is contained in:
parent
e53068dda8
commit
2019612ec5
2 changed files with 3 additions and 25 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libmpdclient
|
||||
PKG_VERSION:=2.9
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=2.10
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=http://www.musicpd.org/download/libmpdclient/2/
|
||||
PGK_MD5SUM:=4b101a36e5c0cf967dc063391260ddbf
|
||||
PGK_MD5SUM:=00606c630b905aa6196330373b366c29
|
||||
|
||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
--- a/src/socket.c
|
||||
+++ b/src/socket.c
|
||||
@@ -43,6 +43,7 @@
|
||||
#else
|
||||
# include <netinet/in.h>
|
||||
# include <arpa/inet.h>
|
||||
+# include <sys/select.h>
|
||||
# include <sys/socket.h>
|
||||
# include <netdb.h>
|
||||
# include <sys/un.h>
|
||||
--- a/src/sync.c
|
||||
+++ b/src/sync.c
|
||||
@@ -33,6 +33,9 @@
|
||||
#include <assert.h>
|
||||
#include <stdlib.h>
|
||||
#include <stdio.h>
|
||||
+#ifndef WIN32
|
||||
+#include <sys/select.h>
|
||||
+#endif
|
||||
#include <fcntl.h>
|
||||
#include <unistd.h>
|
||||
|
Loading…
Reference in a new issue