libmpdclient: Add patch for musl libc compatibility (from upstream repo)
Signed-off-by: Ted Hess <thess@kitschensync.net>
This commit is contained in:
parent
c778155fff
commit
2017a0f6e2
2 changed files with 23 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=libmpdclient
|
||||
PKG_VERSION:=2.9
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=http://www.musicpd.org/download/libmpdclient/2/
|
||||
|
|
22
libs/libmpdclient/patches/001-WIP_musl_compatibility.patch
Normal file
22
libs/libmpdclient/patches/001-WIP_musl_compatibility.patch
Normal file
|
@ -0,0 +1,22 @@
|
|||
--- a/src/socket.c
|
||||
+++ b/src/socket.c
|
||||
@@ -43,6 +43,7 @@
|
||||
#else
|
||||
# include <netinet/in.h>
|
||||
# include <arpa/inet.h>
|
||||
+# include <sys/select.h>
|
||||
# include <sys/socket.h>
|
||||
# include <netdb.h>
|
||||
# include <sys/un.h>
|
||||
--- a/src/sync.c
|
||||
+++ b/src/sync.c
|
||||
@@ -33,6 +33,9 @@
|
||||
#include <assert.h>
|
||||
#include <stdlib.h>
|
||||
#include <stdio.h>
|
||||
+#ifndef WIN32
|
||||
+#include <sys/select.h>
|
||||
+#endif
|
||||
#include <fcntl.h>
|
||||
#include <unistd.h>
|
||||
|
Loading…
Reference in a new issue