gst1-plugins-ugly: Disable debug + other fixes
Added PKG_BUILD_PARALLEL for faster compilation. Removed old rpath hack that is no longer necessary. Removed and replaced two patches with configure arguments. Added PIC as is standard with these. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
63bffa0849
commit
1fe66bf8c2
3 changed files with 9 additions and 54 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=gst1-plugins-ugly
|
||||
PKG_VERSION:=1.15.2
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
|
||||
Ted Hess <thess@kitschensync.net>
|
||||
|
@ -27,6 +27,7 @@ PKG_CONFIG_DEPENDS:= \
|
|||
CONFIG_PACKAGE_gst1-mod-mpeg2dec \
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
@ -96,6 +97,12 @@ GST_VERSION:=1.0
|
|||
CONFIGURE_ARGS += \
|
||||
--disable-debug \
|
||||
--disable-examples \
|
||||
--disable-fatal-warnings \
|
||||
--disable-glib-asserts \
|
||||
--disable-gobject-cast-checks \
|
||||
--disable-gtk-doc-html \
|
||||
--disable-valgrind \
|
||||
--disable-rpath \
|
||||
\
|
||||
--disable-a52dec \
|
||||
--disable-amrnb \
|
||||
|
@ -117,13 +124,7 @@ CONFIGURE_ARGS += \
|
|||
\
|
||||
--without-libiconv-prefix \
|
||||
--without-libintl-prefix \
|
||||
|
||||
TARGET_CFLAGS += -Wno-format-nonliteral
|
||||
|
||||
EXTRA_LDFLAGS+= \
|
||||
-Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
|
||||
$(if $(ICONV_FULL),-liconv) \
|
||||
|
||||
--with-pic
|
||||
|
||||
define Package/gst1-plugins-ugly/install
|
||||
/bin/true
|
||||
|
|
|
@ -1,23 +0,0 @@
|
|||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -1,7 +1,7 @@
|
||||
DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
|
||||
|
||||
SUBDIRS = \
|
||||
- gst-libs gst ext docs m4 tests common pkgconfig
|
||||
+ gst-libs gst ext docs m4 common pkgconfig
|
||||
|
||||
EXTRA_DIST = \
|
||||
depcomp \
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -423,9 +423,6 @@ ext/x264/Makefile
|
||||
docs/Makefile
|
||||
docs/plugins/Makefile
|
||||
docs/version.entities
|
||||
-tests/Makefile
|
||||
-tests/check/Makefile
|
||||
-tests/files/Makefile
|
||||
m4/Makefile
|
||||
pkgconfig/Makefile
|
||||
pkgconfig/gstreamer-plugins-ugly-uninstalled.pc
|
|
@ -1,23 +0,0 @@
|
|||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -1,7 +1,7 @@
|
||||
DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
|
||||
|
||||
SUBDIRS = \
|
||||
- gst-libs gst ext docs m4 common pkgconfig
|
||||
+ gst-libs gst ext m4 common pkgconfig
|
||||
|
||||
EXTRA_DIST = \
|
||||
depcomp \
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -420,9 +420,6 @@ ext/dvdread/Makefile
|
||||
ext/mpeg2dec/Makefile
|
||||
ext/sidplay/Makefile
|
||||
ext/x264/Makefile
|
||||
-docs/Makefile
|
||||
-docs/plugins/Makefile
|
||||
-docs/version.entities
|
||||
m4/Makefile
|
||||
pkgconfig/Makefile
|
||||
pkgconfig/gstreamer-plugins-ugly-uninstalled.pc
|
Loading…
Reference in a new issue