linuxptp: fix build failure
Build is failing because HWTSTAMP_TX_ONESTEP_P2P is defined anymore on
linux net_tstamp.h.
Moreover, the usual way of linuxptp build is looking for system includes
unless user defines differently. That also was tried to fix.
PKG_RELEASE bumped to 3.
Signed-off-by: Paulo Machado <pffmachado@yahoo.com>
(cherry picked from commit 5f64b2d1e4
)
This commit is contained in:
parent
267b490878
commit
1fe19e712f
2 changed files with 15 additions and 2 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=linuxptp
|
||||
PKG_VERSION:=2.0
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)/v$(PKG_VERSION)
|
||||
|
@ -20,6 +20,7 @@ PKG_LICENSE:=GPL-2.0
|
|||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
define Package/linuxptp
|
||||
SECTION:=net
|
||||
|
@ -39,7 +40,8 @@ endef
|
|||
EXTRA_CFLAGS += -DHAVE_CLOCK_ADJTIME -DHAVE_POSIX_SPAWN -DHAVE_ONESTEP_SYNC
|
||||
|
||||
MAKE_VARS += \
|
||||
EXTRA_CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) $(EXTRA_CFLAGS)"
|
||||
EXTRA_CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) $(EXTRA_CFLAGS)" \
|
||||
KBUILD_OUTPUT="$(LINUX_DIR)"
|
||||
|
||||
define Package/linuxptp/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
|
|
11
net/linuxptp/patches/001-fix_kbuild_output.patch
Normal file
11
net/linuxptp/patches/001-fix_kbuild_output.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/incdefs.sh
|
||||
+++ b/incdefs.sh
|
||||
@@ -62,7 +62,7 @@ user_flags()
|
||||
kernel_flags()
|
||||
{
|
||||
prefix=""
|
||||
- tstamp=/usr/include/linux/net_tstamp.h
|
||||
+ tstamp=/include/uapi/linux/net_tstamp.h
|
||||
|
||||
if [ "x$KBUILD_OUTPUT" != "x" ]; then
|
||||
# With KBUILD_OUTPUT set, we are building against
|
Loading…
Reference in a new issue