Merge pull request #12612 from neheb/xfsp
xfsprogs: fix compilation with uClibc-ng
This commit is contained in:
commit
1f813be5df
2 changed files with 6 additions and 2 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=xfsprogs
|
PKG_NAME:=xfsprogs
|
||||||
PKG_VERSION:=5.5.0
|
PKG_VERSION:=5.5.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@KERNEL/linux/utils/fs/xfs/xfsprogs
|
PKG_SOURCE_URL:=@KERNEL/linux/utils/fs/xfs/xfsprogs
|
||||||
|
|
|
@ -1,12 +1,16 @@
|
||||||
--- a/io/mmap.c
|
--- a/io/mmap.c
|
||||||
+++ b/io/mmap.c
|
+++ b/io/mmap.c
|
||||||
@@ -11,6 +11,10 @@
|
@@ -11,6 +11,14 @@
|
||||||
#include "init.h"
|
#include "init.h"
|
||||||
#include "io.h"
|
#include "io.h"
|
||||||
|
|
||||||
+#ifndef MAP_SYNC
|
+#ifndef MAP_SYNC
|
||||||
+#define MAP_SYNC 0
|
+#define MAP_SYNC 0
|
||||||
+#endif
|
+#endif
|
||||||
|
+
|
||||||
|
+#ifndef MAP_SHARED_VALIDATE
|
||||||
|
+#define MAP_SHARED_VALIDATE 0x03
|
||||||
|
+#endif
|
||||||
+
|
+
|
||||||
static cmdinfo_t mmap_cmd;
|
static cmdinfo_t mmap_cmd;
|
||||||
static cmdinfo_t mread_cmd;
|
static cmdinfo_t mread_cmd;
|
||||||
|
|
Loading…
Reference in a new issue