collectd: remove lm-sensors version upper limit
Backport an upstream patch to remove the upper limit of lm-sensors version check, so that using lm-sensors 3.5.0 will work. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
This commit is contained in:
parent
963c841463
commit
1f0a005722
2 changed files with 85 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=collectd
|
PKG_NAME:=collectd
|
||||||
PKG_VERSION:=5.8.1
|
PKG_VERSION:=5.8.1
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=3
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=https://collectd.org/files/ \
|
PKG_SOURCE_URL:=https://collectd.org/files/ \
|
||||||
|
|
|
@ -0,0 +1,84 @@
|
||||||
|
From d5a3c020d33cc33ee8049f54c7b4dffcd123bf83 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Pavel Rochnyack <pavel2000@ngs.ru>
|
||||||
|
Date: Mon, 3 Dec 2018 18:34:14 +0700
|
||||||
|
Subject: [PATCH] sensors: Removed checks for upper limit of
|
||||||
|
SENSORS_API_VERSION
|
||||||
|
|
||||||
|
That makes no more sense after lm-sensors got new maintainers.
|
||||||
|
|
||||||
|
Closes: #3006
|
||||||
|
---
|
||||||
|
src/sensors.c | 17 ++++++-----------
|
||||||
|
1 file changed, 6 insertions(+), 11 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/sensors.c b/src/sensors.c
|
||||||
|
index f4ecda5e49..33982e061a 100644
|
||||||
|
--- a/src/sensors.c
|
||||||
|
+++ b/src/sensors.c
|
||||||
|
@@ -149,7 +149,7 @@ typedef struct featurelist {
|
||||||
|
static char *conffile = SENSORS_CONF_PATH;
|
||||||
|
/* #endif SENSORS_API_VERSION < 0x400 */
|
||||||
|
|
||||||
|
-#elif (SENSORS_API_VERSION >= 0x400) && (SENSORS_API_VERSION < 0x500)
|
||||||
|
+#elif (SENSORS_API_VERSION >= 0x400)
|
||||||
|
typedef struct featurelist {
|
||||||
|
const sensors_chip_name *chip;
|
||||||
|
const sensors_feature *feature;
|
||||||
|
@@ -159,11 +159,6 @@ typedef struct featurelist {
|
||||||
|
|
||||||
|
static char *conffile = NULL;
|
||||||
|
static _Bool use_labels = 0;
|
||||||
|
-/* #endif (SENSORS_API_VERSION >= 0x400) && (SENSORS_API_VERSION < 0x500) */
|
||||||
|
-
|
||||||
|
-#else /* if SENSORS_API_VERSION >= 0x500 */
|
||||||
|
-#error "This version of libsensors is not supported yet. Please report this " \
|
||||||
|
- "as bug."
|
||||||
|
#endif
|
||||||
|
|
||||||
|
static featurelist_t *first_feature = NULL;
|
||||||
|
@@ -223,7 +218,7 @@ static int sensors_config(const char *key, const char *value) {
|
||||||
|
if (IS_TRUE(value))
|
||||||
|
ignorelist_set_invert(sensor_list, 0);
|
||||||
|
}
|
||||||
|
-#if (SENSORS_API_VERSION >= 0x400) && (SENSORS_API_VERSION < 0x500)
|
||||||
|
+#if (SENSORS_API_VERSION >= 0x400)
|
||||||
|
else if (strcasecmp(key, "UseLabels") == 0) {
|
||||||
|
use_labels = IS_TRUE(value) ? 1 : 0;
|
||||||
|
}
|
||||||
|
@@ -353,7 +348,7 @@ static int sensors_load_conf(void) {
|
||||||
|
} /* while sensors_get_detected_chips */
|
||||||
|
/* #endif SENSORS_API_VERSION < 0x400 */
|
||||||
|
|
||||||
|
-#elif (SENSORS_API_VERSION >= 0x400) && (SENSORS_API_VERSION < 0x500)
|
||||||
|
+#elif (SENSORS_API_VERSION >= 0x400)
|
||||||
|
chip_num = 0;
|
||||||
|
while ((chip = sensors_get_detected_chips(NULL, &chip_num)) != NULL) {
|
||||||
|
const sensors_feature *feature;
|
||||||
|
@@ -410,7 +405,7 @@ static int sensors_load_conf(void) {
|
||||||
|
} /* while (subfeature) */
|
||||||
|
} /* while (feature) */
|
||||||
|
} /* while (chip) */
|
||||||
|
-#endif /* (SENSORS_API_VERSION >= 0x400) && (SENSORS_API_VERSION < 0x500) */
|
||||||
|
+#endif /* (SENSORS_API_VERSION >= 0x400) */
|
||||||
|
|
||||||
|
if (first_feature == NULL) {
|
||||||
|
sensors_cleanup();
|
||||||
|
@@ -485,7 +480,7 @@ static int sensors_read(void) {
|
||||||
|
} /* for fl = first_feature .. NULL */
|
||||||
|
/* #endif SENSORS_API_VERSION < 0x400 */
|
||||||
|
|
||||||
|
-#elif (SENSORS_API_VERSION >= 0x400) && (SENSORS_API_VERSION < 0x500)
|
||||||
|
+#elif (SENSORS_API_VERSION >= 0x400)
|
||||||
|
for (featurelist_t *fl = first_feature; fl != NULL; fl = fl->next) {
|
||||||
|
double value;
|
||||||
|
int status;
|
||||||
|
@@ -528,7 +523,7 @@ static int sensors_read(void) {
|
||||||
|
|
||||||
|
sensors_submit(plugin_instance, type, type_instance, value);
|
||||||
|
} /* for fl = first_feature .. NULL */
|
||||||
|
-#endif /* (SENSORS_API_VERSION >= 0x400) && (SENSORS_API_VERSION < 0x500) */
|
||||||
|
+#endif /* (SENSORS_API_VERSION >= 0x400) */
|
||||||
|
|
||||||
|
return 0;
|
||||||
|
} /* int sensors_read */
|
||||||
|
|
Loading…
Reference in a new issue