treewide: quote CC and CXX
When CC is set to e.g. "ccache mips-openwrt-linux-musl-gcc" it needs to be quoted to avoid word splitting on substitution. Signed-off-by: Paul Fertser <fercerpav@gmail.com>
This commit is contained in:
parent
dd48483a60
commit
1e8584dc58
7 changed files with 9 additions and 9 deletions
|
@ -49,7 +49,7 @@ define Package/chicken-scheme-interpreter/description
|
||||||
For more information, please refer to the Chicken Scheme website at https://call-cc.org.
|
For more information, please refer to the Chicken Scheme website at https://call-cc.org.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
MAKE_FLAGS += PLATFORM=linux C_COMPILER=$(TARGET_CC) LINKER=$(TARGET_CC) PREFIX=/usr C_COMPILER_OPTIMIZATION_OPTIONS="$(TARGET_CFLAGS)"
|
MAKE_FLAGS += PLATFORM=linux C_COMPILER="$(TARGET_CC)" LINKER="$(TARGET_CC)" PREFIX=/usr C_COMPILER_OPTIMIZATION_OPTIONS="$(TARGET_CFLAGS)"
|
||||||
|
|
||||||
# not installed:
|
# not installed:
|
||||||
# - csc and chicken, the compiler
|
# - csc and chicken, the compiler
|
||||||
|
|
|
@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=liburing
|
PKG_NAME:=liburing
|
||||||
PKG_VERSION:=2.3
|
PKG_VERSION:=2.3
|
||||||
PKG_RELEASE:=$(AUTORELEASE)
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://git.kernel.dk/cgit/liburing/snapshot
|
PKG_SOURCE_URL:=https://git.kernel.dk/cgit/liburing/snapshot
|
||||||
|
@ -32,7 +32,7 @@ define Package/liburing/description
|
||||||
For more info on io_uring, please see: https://kernel.dk/io_uring.pdf
|
For more info on io_uring, please see: https://kernel.dk/io_uring.pdf
|
||||||
endef
|
endef
|
||||||
|
|
||||||
CONFIGURE_ARGS:=--prefix=$(CONFIGURE_PREFIX) --cc=${TARGET_CC}
|
CONFIGURE_ARGS:=--prefix=$(CONFIGURE_PREFIX) --cc="${TARGET_CC}"
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
$(MAKE) $(PKG_BUILD_DIR) \
|
$(MAKE) $(PKG_BUILD_DIR) \
|
||||||
|
|
|
@ -32,7 +32,7 @@ endef
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
cd $(PKG_BUILD_DIR)/PcapPlusPlus; ./configure-linux.sh --install-dir /usr
|
cd $(PKG_BUILD_DIR)/PcapPlusPlus; ./configure-linux.sh --install-dir /usr
|
||||||
make -C $(PKG_BUILD_DIR)/PcapPlusPlus CXXFLAGS="$(TARGET_CXXFLAGS) -fPIC" CFLAGS="$(TARGET_CFLAGS) -fPIC" CXX=$(TARGET_CXX) CC=$(TARGET_CC) AR=$(TARGET_AR) libs
|
make -C $(PKG_BUILD_DIR)/PcapPlusPlus CXXFLAGS="$(TARGET_CXXFLAGS) -fPIC" CFLAGS="$(TARGET_CFLAGS) -fPIC" CXX="$(TARGET_CXX)" CC="$(TARGET_CC)" AR=$(TARGET_AR) libs
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/InstallDev
|
define Build/InstallDev
|
||||||
|
|
|
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
||||||
PKG_NAME:=isc-dhcp
|
PKG_NAME:=isc-dhcp
|
||||||
UPSTREAM_NAME:=dhcp
|
UPSTREAM_NAME:=dhcp
|
||||||
PKG_VERSION:=4.4.3
|
PKG_VERSION:=4.4.3
|
||||||
PKG_RELEASE:=$(AUTORELEASE)
|
PKG_RELEASE:=6
|
||||||
|
|
||||||
PKG_LICENSE:=BSD-3-Clause
|
PKG_LICENSE:=BSD-3-Clause
|
||||||
PKG_LICENSE_FILES:=LICENSE
|
PKG_LICENSE_FILES:=LICENSE
|
||||||
|
|
|
@ -5,7 +5,7 @@
|
||||||
rm -rf ${cleandirs} ${cleanfiles} ; \
|
rm -rf ${cleandirs} ${cleanfiles} ; \
|
||||||
(cd ${bindsrcdir} && \
|
(cd ${bindsrcdir} && \
|
||||||
- ./configure ${bindconfig} > ${binddir}/configure.log); \
|
- ./configure ${bindconfig} > ${binddir}/configure.log); \
|
||||||
+ export CC=${CROSS_CC} AR=${TARGET_AR} RANLIB=${TARGET_RANLIB} && \
|
+ export CC="${CROSS_CC}" AR=${TARGET_AR} RANLIB=${TARGET_RANLIB} && \
|
||||||
+ ./configure ${bindconfig} --disable-atomic \
|
+ ./configure ${bindconfig} --disable-atomic \
|
||||||
+ --disable-kqueue --disable-epoll --disable-kqueue \
|
+ --disable-kqueue --disable-epoll --disable-kqueue \
|
||||||
+ --disable-epoll --disable-devpoll --without-openssl \
|
+ --disable-epoll --disable-devpoll --without-openssl \
|
||||||
|
|
|
@ -3,7 +3,7 @@
|
||||||
@@ -57,6 +57,7 @@ bind1:
|
@@ -57,6 +57,7 @@ bind1:
|
||||||
rm -rf ${cleandirs} ${cleanfiles} ; \
|
rm -rf ${cleandirs} ${cleanfiles} ; \
|
||||||
(cd ${bindsrcdir} && \
|
(cd ${bindsrcdir} && \
|
||||||
export CC=${CROSS_CC} AR=${TARGET_AR} RANLIB=${TARGET_RANLIB} && \
|
export CC="${CROSS_CC}" AR=${TARGET_AR} RANLIB=${TARGET_RANLIB} && \
|
||||||
+ ac_cv_func_catgets=no \
|
+ ac_cv_func_catgets=no \
|
||||||
./configure ${bindconfig} --disable-atomic \
|
./configure ${bindconfig} --disable-atomic \
|
||||||
--disable-kqueue --disable-epoll --disable-kqueue \
|
--disable-kqueue --disable-epoll --disable-kqueue \
|
||||||
|
|
|
@ -38,8 +38,8 @@ MAKE_VARS += \
|
||||||
GOPATH=$(GO_PKG_BUILD_DIR) \
|
GOPATH=$(GO_PKG_BUILD_DIR) \
|
||||||
GOCACHE=$(GO_BUILD_CACHE_DIR) \
|
GOCACHE=$(GO_BUILD_CACHE_DIR) \
|
||||||
GOROOT_FINAL=$(GO_TARGET_ROOT) \
|
GOROOT_FINAL=$(GO_TARGET_ROOT) \
|
||||||
CC=$(TARGET_CC) \
|
CC="$(TARGET_CC)" \
|
||||||
CXX=$(TARGET_CXX) \
|
CXX="$(TARGET_CXX)" \
|
||||||
$(GO_PKG_VARS)
|
$(GO_PKG_VARS)
|
||||||
MAKE_FLAGS += \
|
MAKE_FLAGS += \
|
||||||
COMMIT=$(PKG_SOURCE_VERSION)
|
COMMIT=$(PKG_SOURCE_VERSION)
|
||||||
|
|
Loading…
Reference in a new issue