Merge pull request #13064 from neheb/linkn

linknx: fix compilation without sys/cdefs
This commit is contained in:
Rosen Penev 2020-08-11 10:12:27 -07:00 committed by GitHub
commit 1e70e0cb72
No known key found for this signature in database
GPG key ID: 4AEE18F83AFDEB23
2 changed files with 27 additions and 1 deletions

View file

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=linknx
PKG_VERSION:=0.0.1.38
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-${PKG_VERSION}.tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/linknx/linknx/tar.gz/$(PKG_VERSION)?

View file

@ -0,0 +1,26 @@
--- a/include/eibclient.h
+++ b/include/eibclient.h
@@ -27,11 +27,12 @@
#ifndef EIBCLIENT_H
#define EIBCLIENT_H
-#include "sys/cdefs.h"
#include "stdint.h"
#include <pthsem.h>
-__BEGIN_DECLS;
+#ifdef __cplusplus
+extern "C" {
+#endif
#include "eibloadresult.h"
@@ -705,5 +706,7 @@ BCU_LOAD_RESULT EIB_LoadImage (EIBConnection * con, const uint8_t * image,
*/
int EIB_LoadImage_async (EIBConnection * con, const uint8_t * image, int len);
-__END_DECLS
+#ifdef __cplusplus
+}
+#endif
#endif