commit
1e70a8c758
2 changed files with 70 additions and 0 deletions
57
net/atftp/Makefile
Normal file
57
net/atftp/Makefile
Normal file
|
@ -0,0 +1,57 @@
|
|||
#
|
||||
# Copyright (C) 2006-2014 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=atftp
|
||||
PKG_VERSION:=0.7.1
|
||||
PKG_RELEASE:=3
|
||||
PKG_MAINTAINER:=Daniel Danzberger <daniel@dd-wrt.com>
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://freefr.dl.sourceforge.net/project/atftp/
|
||||
PKG_MD5SUM:=367bf401965fbed04585b1229c2191a8
|
||||
|
||||
PKG_BUILD_DEPENDS:=libpcre libreadline
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/atftp/Default
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=TFTP
|
||||
SUBMENU:=File Transfer
|
||||
endef
|
||||
|
||||
define Package/atftp
|
||||
$(call Package/atftp/Default)
|
||||
DEPENDS:=+libreadline +libncurses
|
||||
TITLE+= client
|
||||
endef
|
||||
|
||||
define Package/atftpd
|
||||
$(call Package/atftp/Default)
|
||||
DEPENDS:=+libpcre +libpthread
|
||||
TITLE+= server
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--disable-libwrap
|
||||
|
||||
define Package/atftp/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/atftp $(1)/usr/sbin/
|
||||
endef
|
||||
|
||||
define Package/atftpd/install
|
||||
$(INSTALL_DIR) $(1)/etc
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/atftpd $(1)/usr/sbin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,atftp))
|
||||
$(eval $(call BuildPackage,atftpd))
|
13
net/atftp/patches/01-missing-u_char-type-patch.patch
Normal file
13
net/atftp/patches/01-missing-u_char-type-patch.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff --git a/tftpd.h b/tftpd.h
|
||||
index 945065e..4c2f214 100644
|
||||
--- a/tftpd.h
|
||||
+++ b/tftpd.h
|
||||
@@ -46,7 +46,7 @@ struct thread_data {
|
||||
char *mc_addr; /* multicast address */
|
||||
struct sockaddr_storage sa_mcast;
|
||||
union ip_mreq_storage mcastaddr;
|
||||
- u_char mcast_ttl;
|
||||
+ unsigned char mcast_ttl;
|
||||
|
||||
/*
|
||||
* Self can read/write until client_ready is set. Then only allowed to read.
|
Loading…
Reference in a new issue