softflowd: fix compilation with newer musl
__uid_t is a glibc extension. Switch to standard uid_t. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
e06d851a42
commit
1e3051c5ad
2 changed files with 12 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=softflowd
|
||||
PKG_VERSION:=1.0.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/irino/softflowd/tar.gz/softflowd-$(PKG_VERSION)?
|
||||
|
|
11
net/softflowd/patches/020-uid.patch
Normal file
11
net/softflowd/patches/020-uid.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/common.h
|
||||
+++ b/common.h
|
||||
@@ -179,7 +179,7 @@ struct ip6_ext {
|
||||
|
||||
/* following lines are copy from unistd.h in Linux for avoidance warnings in compilation */
|
||||
#if defined(HAVE_SETRESGID) && !defined(_GNU_SOURCE)
|
||||
-extern int setresgid (__uid_t __ruid, __uid_t __euid, __uid_t __suid);
|
||||
+extern int setresgid (uid_t __ruid, uid_t __euid, uid_t __suid);
|
||||
#endif
|
||||
#if defined(HAVE_SETRESUID) && !defined(_GNU_SOURCE)
|
||||
extern int setresuid (__uid_t __ruid, __uid_t __euid, __uid_t __suid);
|
Loading…
Reference in a new issue