sedutil: fix compilation with GCC13
Upstream backport. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
d4ed50045f
commit
1dfb94dc01
2 changed files with 26 additions and 1 deletions
|
@ -1,7 +1,7 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=sedutil
|
PKG_NAME:=sedutil
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE_PROTO:=git
|
PKG_SOURCE_PROTO:=git
|
||||||
PKG_SOURCE_URL=https://github.com/Drive-Trust-Alliance/sedutil
|
PKG_SOURCE_URL=https://github.com/Drive-Trust-Alliance/sedutil
|
||||||
|
|
25
utils/sedutil/patches/010-gcc13.patch
Normal file
25
utils/sedutil/patches/010-gcc13.patch
Normal file
|
@ -0,0 +1,25 @@
|
||||||
|
From b47102bf6066e5342fdbb69bd767cd70a0a59bf9 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Yaakov Selkowitz <yselkowi@redhat.com>
|
||||||
|
Date: Sun, 19 Feb 2023 21:28:10 -0500
|
||||||
|
Subject: [PATCH] Fix build with GCC 13
|
||||||
|
|
||||||
|
As in previous versions, libstdc++ in GCC 13 has trimmed internal
|
||||||
|
inclusion of standard headers, necessitating their proper inclusion
|
||||||
|
when used:
|
||||||
|
|
||||||
|
https://gcc.gnu.org/gcc-13/porting_to.html
|
||||||
|
---
|
||||||
|
Common/DtaOptions.h | 2 ++
|
||||||
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
|
--- a/Common/DtaOptions.h
|
||||||
|
+++ b/Common/DtaOptions.h
|
||||||
|
@@ -21,6 +21,8 @@ along with sedutil. If not, see <http:/
|
||||||
|
#ifndef _DTAOPTIONS_H
|
||||||
|
#define _DTAOPTIONS_H
|
||||||
|
|
||||||
|
+#include <stdint.h>
|
||||||
|
+
|
||||||
|
/** Output modes */
|
||||||
|
typedef enum _sedutiloutput {
|
||||||
|
sedutilNormal,
|
Loading…
Reference in a new issue