tcsh: remove patches as they are now upstream
Signed-off-by: Nuno Goncalves <nunojpg@gmail.com>
This commit is contained in:
parent
3c698f2285
commit
1da82b171c
4 changed files with 10 additions and 47 deletions
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2011-2015 OpenWrt.org
|
||||
# Copyright (C) 2011-2016 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -7,17 +7,16 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=tcsh
|
||||
PKG_VERSION:=6.19.00
|
||||
PKG_RELEASE:=4
|
||||
PKG_VERSION:=6.19.01
|
||||
PKG_RELEASE:=$(PKG_SOURCE_VERSION)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:= \
|
||||
http://ftp.funet.fi/pub/mirrors/ftp.astron.com/pub/tcsh/ \
|
||||
http://ftp.funet.fi/pub/mirrors/ftp.astron.com/pub/tcsh/old/ \
|
||||
ftp://ftp.astron.com/pub/tcsh/ \
|
||||
ftp://ftp.astron.com/pub/tcsh/old
|
||||
PKG_MD5SUM:=f5f854833578647795bc906dd4bcb5d5
|
||||
PKG_LICENSE:=BSD-4-Clause-UC
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=git://github.com/tcsh-org/tcsh
|
||||
PKG_SOURCE_VERSION:=26ef8ea3dd79fbe5311d80a69d490c0d46151543
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
PKG_LICENSE_FILES:=Copyright
|
||||
|
||||
PKG_MAINTAINER:=Nuno Goncalves <nunojpg@gmail.com>
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -449,7 +449,7 @@ pure:$(P) ${OBJS}
|
||||
|
||||
gethost: gethost.c sh.err.h tc.const.h sh.h
|
||||
rm -f gethost
|
||||
- ${CC_FOR_GETHOST} -o gethost ${CPPFLAGS} ${CFLAGS} $(srcdir)/gethost.c
|
||||
+ ${CC_FOR_GETHOST} -o gethost ${CPPFLAGS} $(srcdir)/gethost.c
|
||||
|
||||
tc.defs.c: gethost host.defs
|
||||
@rm -f $@.tmp
|
|
@ -1,14 +0,0 @@
|
|||
--- a/config_f.h
|
||||
+++ b/config_f.h
|
||||
@@ -135,11 +135,7 @@
|
||||
* This can be much slower and no memory statistics will be
|
||||
* provided.
|
||||
*/
|
||||
-#if defined(__MACHTEN__) || defined(PURIFY) || defined(MALLOC_TRACE) || defined(_OSD_POSIX) || defined(__MVS__) || defined (__CYGWIN__) || defined(__GLIBC__) || defined(__OpenBSD__) || defined(__APPLE__)
|
||||
# define SYSMALLOC
|
||||
-#else
|
||||
-# undef SYSMALLOC
|
||||
-#endif
|
||||
|
||||
/*
|
||||
* USE_ACCESS Use access(2) rather than stat(2) when POSIX is defined.
|
|
@ -1,11 +0,0 @@
|
|||
--- a/sh.proc.c
|
||||
+++ b/sh.proc.c
|
||||
@@ -48,7 +48,7 @@ RCSID("$tcsh: sh.proc.c,v 3.127 2015/02/
|
||||
#endif /* aiws */
|
||||
|
||||
#if defined(_BSD) || (defined(IRIS4D) && __STDC__) || defined(__lucid) || defined(__linux__) || defined(__GNU__) || defined(__GLIBC__)
|
||||
-# if !defined(__ANDROID__)
|
||||
+# if !(defined(__ANDROID__) || (defined(__linux__) && !defined(__GLIBC__)))
|
||||
# define BSDWAIT
|
||||
# endif
|
||||
#endif /* _BSD || (IRIS4D && __STDC__) || __lucid || glibc */
|
Loading…
Reference in a new issue