wget: update to 1.20
Signed-off-by: Peter Wagner <tripolar@gmx.at>
This commit is contained in:
parent
b931383257
commit
1d8fd9d16e
2 changed files with 3 additions and 45 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=wget
|
||||
PKG_VERSION:=1.19.5
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=1.20
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
|
||||
PKG_HASH:=b39212abe1a73f2b28f4c6cb223c738559caac91d6e416a6d91d4b9d55c9faee
|
||||
PKG_HASH:=8a057925c74c059d9e37de63a63b450da66c5c1c8cef869a6df420b3bb45a0cf
|
||||
PKG_MAINTAINER:=Peter Wagner <tripolar@gmx.at>
|
||||
PKG_LICENSE:=GPL-3.0+
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
|
|
@ -1,42 +0,0 @@
|
|||
From a3643c6076e60f778e069340100e86bec5786e5f Mon Sep 17 00:00:00 2001
|
||||
From: Rosen Penev <rosenp@gmail.com>
|
||||
Date: Thu, 8 Nov 2018 16:01:05 -0800
|
||||
Subject: [PATCH] openssl: Do not use engines when OpenSSL does not support
|
||||
|
||||
* src/openssl.c: Check for OPENSSL_NO_ENGINE before
|
||||
including openssl/engine.h and before calling ENGINE_load_builtin_engines()
|
||||
|
||||
Fixes compilation with no engines compiled.
|
||||
|
||||
Copyright-paperwork-exempt: Yes
|
||||
Signed-off-by: Rosen Penev <rosenp@gmail.com>
|
||||
---
|
||||
src/openssl.c | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/src/openssl.c b/src/openssl.c
|
||||
index 6cf4afe9..73e7f0f4 100644
|
||||
--- a/src/openssl.c
|
||||
+++ b/src/openssl.c
|
||||
@@ -43,8 +43,10 @@ as that of the covered work. */
|
||||
#include <openssl/bio.h>
|
||||
#if OPENSSL_VERSION_NUMBER >= 0x00907000
|
||||
#include <openssl/conf.h>
|
||||
+#ifndef OPENSSL_NO_ENGINE
|
||||
#include <openssl/engine.h>
|
||||
#endif
|
||||
+#endif
|
||||
|
||||
#include "utils.h"
|
||||
#include "connect.h"
|
||||
@@ -193,7 +195,9 @@ ssl_init (void)
|
||||
|
||||
#if OPENSSL_VERSION_NUMBER >= 0x00907000
|
||||
OPENSSL_load_builtin_modules();
|
||||
+#ifndef OPENSSL_NO_ENGINE
|
||||
ENGINE_load_builtin_engines();
|
||||
+#endif
|
||||
CONF_modules_load_file(NULL, NULL,
|
||||
CONF_MFLAGS_DEFAULT_SECTION|CONF_MFLAGS_IGNORE_MISSING_FILE);
|
||||
#endif
|
||||
|
Loading…
Reference in a new issue