Merge pull request #8770 from neheb/es
[18.06] espeak: Fix build issues. Cleanup patches
This commit is contained in:
commit
1d44e408f4
3 changed files with 27 additions and 2096 deletions
|
@ -1,6 +1,4 @@
|
|||
#
|
||||
# Copyright (C) 2014 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
@ -9,7 +7,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=espeak
|
||||
PKG_VERSION:=1.48.04
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-source.zip
|
||||
PKG_SOURCE_URL:=@SF/espeak
|
||||
|
@ -45,6 +43,12 @@ MAKE_FLAGS+= \
|
|||
|
||||
MAKE_PATH:=./src
|
||||
|
||||
# Use system header for portaudio
|
||||
define Build/Prepare
|
||||
$(call Build/Prepare/Default)
|
||||
rm $(PKG_BUILD_DIR)/src/portaudio.h
|
||||
endef
|
||||
|
||||
define Package/espeak/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/espeak $(1)/usr/bin/
|
||||
|
|
|
@ -0,0 +1,20 @@
|
|||
--- a/src/tr_languages.cpp
|
||||
+++ b/src/tr_languages.cpp
|
||||
@@ -198,7 +198,7 @@ static const unsigned short chars_ignore
|
||||
0x200d, 1, // zero width joiner
|
||||
0, 0 };
|
||||
|
||||
-const char string_ordinal[] = {0xc2,0xba,0}; // masculine ordinal character, UTF-8
|
||||
+const unsigned char string_ordinal[] = {0xc2,0xba,0}; // masculine ordinal character, UTF-8
|
||||
|
||||
|
||||
static Translator* NewTranslator(void)
|
||||
@@ -758,7 +758,7 @@ Translator *SelectTranslator(const char
|
||||
tr->langopts.stress_flags = S_FINAL_SPANISH | S_FINAL_DIM_ONLY | S_FINAL_NO_2;
|
||||
tr->langopts.numbers = NUM_SINGLE_STRESS | NUM_DECIMAL_COMMA | NUM_AND_UNITS | NUM_OMIT_1_HUNDRED | NUM_OMIT_1_THOUSAND | NUM_ROMAN | NUM_ROMAN_ORDINAL;
|
||||
tr->langopts.numbers2 = NUM2_ORDINAL_NO_AND;
|
||||
- tr->langopts.roman_suffix = string_ordinal;
|
||||
+ tr->langopts.roman_suffix = (const char *)string_ordinal;
|
||||
}
|
||||
else
|
||||
if(name2 == L_pap)
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue