Merge branch 'coreutils' of https://github.com/rkunze/openwrt-packages
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
This commit is contained in:
commit
1d2d2f509e
4 changed files with 86 additions and 28 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=coreutils
|
||||
PKG_VERSION:=8.16
|
||||
PKG_VERSION:=8.23
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@GNU/coreutils
|
||||
PKG_MD5SUM:=89b06f91634208dceba7b36ad1f9e8b9
|
||||
PKG_MD5SUM:=abed135279f87ad6762ce57ff6d89c41
|
||||
PKG_BUILD_DEPENDS:=libpthread
|
||||
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
|
||||
|
||||
|
@ -36,6 +36,12 @@ DEPENDS_sort = +libpthread
|
|||
DEPENDS_timeout = +librt
|
||||
DEPENDS_expr = +libgmp
|
||||
DEPENDS_factor = +libgmp
|
||||
DEPENDS_cp = +libacl
|
||||
DEPENDS_dir = +libacl
|
||||
DEPENDS_install = +libacl
|
||||
DEPENDS_ls = +libacl
|
||||
DEPENDS_mv = +libacl
|
||||
DEPENDS_vdir = +libacl
|
||||
|
||||
define Package/coreutils/Default
|
||||
SECTION:=utils
|
||||
|
@ -89,7 +95,7 @@ define Build/Compile
|
|||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
SHELL="/bin/bash" \
|
||||
all install install-root
|
||||
all install
|
||||
endef
|
||||
|
||||
define Package/coreutils/install
|
||||
|
|
|
@ -4,19 +4,86 @@
|
|||
|
||||
ALL_RECURSIVE_TARGETS =
|
||||
|
||||
-SUBDIRS = lib src doc man po tests gnulib-tests
|
||||
+SUBDIRS = lib src po
|
||||
-SUBDIRS = po . gnulib-tests
|
||||
+SUBDIRS = po
|
||||
|
||||
changelog_etc = \
|
||||
ChangeLog-2005 \
|
||||
@@ -213,6 +213,4 @@ AM_CPPFLAGS = -Ilib -I$(top_srcdir)/lib
|
||||
|
||||
include $(top_srcdir)/lib/local.mk
|
||||
include $(top_srcdir)/src/local.mk
|
||||
-include $(top_srcdir)/doc/local.mk
|
||||
-include $(top_srcdir)/man/local.mk
|
||||
-include $(top_srcdir)/tests/local.mk
|
||||
+
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -1639,7 +1639,7 @@ top_srcdir = @top_srcdir@
|
||||
|
||||
# Some tests always need root privileges, others need them only sometimes.
|
||||
ALL_RECURSIVE_TARGETS = install-root check-root distcheck-hook
|
||||
-SUBDIRS = lib src doc man po tests gnulib-tests
|
||||
+SUBDIRS = lib src po
|
||||
@@ -159,8 +159,7 @@ build_triplet = @build@
|
||||
host_triplet = @host@
|
||||
DIST_COMMON = $(top_srcdir)/lib/local.mk $(srcdir)/lib/gnulib.mk \
|
||||
$(top_srcdir)/src/local.mk $(srcdir)/src/cu-progs.mk \
|
||||
- $(top_srcdir)/src/single-binary.mk $(top_srcdir)/doc/local.mk \
|
||||
- $(top_srcdir)/man/local.mk $(top_srcdir)/tests/local.mk \
|
||||
+ $(top_srcdir)/src/single-binary.mk \
|
||||
INSTALL NEWS README AUTHORS ChangeLog $(srcdir)/Makefile.in \
|
||||
$(srcdir)/Makefile.am $(top_srcdir)/configure \
|
||||
$(am__configure_deps) $(top_srcdir)/lib/config.hin ABOUT-NLS \
|
||||
@@ -2276,11 +2275,7 @@ RECURSIVE_TARGETS = all-recursive check-
|
||||
install-ps-recursive install-recursive installcheck-recursive \
|
||||
installdirs-recursive pdf-recursive ps-recursive \
|
||||
tags-recursive uninstall-recursive
|
||||
-am__can_run_installinfo = \
|
||||
- case $$AM_UPDATE_INFO_DIR in \
|
||||
- n|no|NO) false;; \
|
||||
- *) (install-info --version) >/dev/null 2>&1;; \
|
||||
- esac
|
||||
+am__can_run_installinfo = false
|
||||
am__vpath_adj_setup = srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`;
|
||||
am__vpath_adj = case $$p in \
|
||||
$(srcdir)/*) f=`echo "$$p" | sed "s|^$$srcdirstrip/||"`;; \
|
||||
@@ -2606,7 +2601,7 @@ EOVERFLOW_HIDDEN = @EOVERFLOW_HIDDEN@
|
||||
EOVERFLOW_VALUE = @EOVERFLOW_VALUE@
|
||||
ERRNO_H = @ERRNO_H@
|
||||
EXEEXT = @EXEEXT@
|
||||
-EXTRA_MANS = @EXTRA_MANS@
|
||||
+EXTRA_MANS =
|
||||
FLOAT_H = @FLOAT_H@
|
||||
FNMATCH_H = @FNMATCH_H@
|
||||
GETADDRINFO_LIB = @GETADDRINFO_LIB@
|
||||
@@ -3820,7 +3815,7 @@ libexecdir = @libexecdir@
|
||||
lispdir = @lispdir@
|
||||
localedir = @localedir@
|
||||
localstatedir = @localstatedir@
|
||||
-man1_MANS = @man1_MANS@
|
||||
+man1_MANS =
|
||||
mandir = @mandir@
|
||||
mkdir_p = @mkdir_p@
|
||||
oldincludedir = @oldincludedir@
|
||||
@@ -3843,7 +3838,7 @@ top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
ALL_RECURSIVE_TARGETS = distcheck-hook check-root
|
||||
-SUBDIRS = po . gnulib-tests
|
||||
+SUBDIRS = po
|
||||
changelog_etc = \
|
||||
ChangeLog-2005 \
|
||||
ChangeLog-2006 \
|
||||
@@ -5767,7 +5762,7 @@ all: $(BUILT_SOURCES)
|
||||
.SUFFIXES: .1 .c .dvi .log .o .obj .pl .pl$(EXEEXT) .ps .sed .sh .sh$(EXEEXT) .sin .trs .x .xpl .xpl$(EXEEXT) .y
|
||||
am--refresh: Makefile
|
||||
@:
|
||||
-$(srcdir)/Makefile.in: $(srcdir)/Makefile.am $(top_srcdir)/lib/local.mk $(srcdir)/lib/gnulib.mk $(top_srcdir)/src/local.mk $(srcdir)/src/cu-progs.mk $(top_srcdir)/src/single-binary.mk $(top_srcdir)/doc/local.mk $(top_srcdir)/man/local.mk $(top_srcdir)/tests/local.mk $(am__configure_deps)
|
||||
+$(srcdir)/Makefile.in: $(srcdir)/Makefile.am $(top_srcdir)/lib/local.mk $(srcdir)/lib/gnulib.mk $(top_srcdir)/src/local.mk $(srcdir)/src/cu-progs.mk $(top_srcdir)/src/single-binary.mk $(am__configure_deps)
|
||||
@for dep in $?; do \
|
||||
case '$(am__configure_deps)' in \
|
||||
*$$dep*) \
|
||||
@@ -5790,7 +5785,7 @@ Makefile: $(srcdir)/Makefile.in $(top_bu
|
||||
echo ' cd $(top_builddir) && $(SHELL) ./config.status $@ $(am__depfiles_maybe)'; \
|
||||
cd $(top_builddir) && $(SHELL) ./config.status $@ $(am__depfiles_maybe);; \
|
||||
esac;
|
||||
-$(top_srcdir)/lib/local.mk $(srcdir)/lib/gnulib.mk $(top_srcdir)/src/local.mk $(srcdir)/src/cu-progs.mk $(top_srcdir)/src/single-binary.mk $(top_srcdir)/doc/local.mk $(top_srcdir)/man/local.mk $(top_srcdir)/tests/local.mk:
|
||||
+$(top_srcdir)/lib/local.mk $(srcdir)/lib/gnulib.mk $(top_srcdir)/src/local.mk $(srcdir)/src/cu-progs.mk $(top_srcdir)/src/single-binary.mk:
|
||||
|
||||
$(top_builddir)/config.status: $(top_srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
|
||||
$(SHELL) ./config.status --recheck
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/lib/pthread.in.h
|
||||
+++ b/lib/pthread.in.h
|
||||
@@ -232,6 +232,9 @@ pthread_mutex_unlock (pthread_mutex_t *m
|
||||
@@ -252,6 +252,9 @@ pthread_mutex_unlock (pthread_mutex_t *m
|
||||
|
||||
/* Approximate spinlocks with mutexes. */
|
||||
|
||||
|
@ -9,4 +9,4 @@
|
|||
+#endif
|
||||
typedef pthread_mutex_t pthread_spinlock_t;
|
||||
|
||||
static inline int
|
||||
_GL_PTHREAD_INLINE int
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
diff --git a/lib/stdio.in.h b/lib/stdio.in.h
|
||||
index 9dc7c4a..9fdac77 100644
|
||||
--- a/lib/stdio.in.h
|
||||
+++ b/lib/stdio.in.h
|
||||
@@ -711,10 +711,6 @@ _GL_CXXALIAS_SYS (gets, char *, (char *s));
|
||||
# undef gets
|
||||
# endif
|
||||
_GL_CXXALIASWARN (gets);
|
||||
-/* It is very rare that the developer ever has full control of stdin,
|
||||
- so any use of gets warrants an unconditional warning. Assume it is
|
||||
- always declared, since it is required by C89. */
|
||||
-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
|
||||
#endif
|
||||
|
||||
|
Loading…
Reference in a new issue