alpine: try to make reproducible
Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
04c911aeb0
commit
1d04c219db
2 changed files with 19 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=alpine
|
||||
PKG_VERSION:=2.24
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=http://alpine.x10host.com/alpine/release/src
|
||||
|
|
18
mail/alpine/patches/020-reproducible.patch
Normal file
18
mail/alpine/patches/020-reproducible.patch
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- a/pico/blddate.c
|
||||
+++ b/pico/blddate.c
|
||||
@@ -28,6 +28,7 @@ main(argc, argv)
|
||||
exit(1);
|
||||
}
|
||||
|
||||
+/*
|
||||
time(<ime);
|
||||
t = localtime(<ime);
|
||||
fprintf(outfile,"char datestamp[]=\"%02d-%s-%d\";\n", t->tm_mday,
|
||||
@@ -46,6 +47,7 @@ main(argc, argv)
|
||||
1900 + t->tm_year);
|
||||
|
||||
fprintf(outfile, "char hoststamp[]=\"random-pc\";\n");
|
||||
+*/
|
||||
fprintf(outfile, "char configoptions[] = \"\";\n");
|
||||
|
||||
fclose(outfile);
|
Loading…
Reference in a new issue