Merge pull request #1219 from hauke/tor
This should fix building tor and updates it to the most recent version.
This commit is contained in:
commit
1c0c31b69f
2 changed files with 5 additions and 4 deletions
|
@ -8,13 +8,13 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=tor
|
PKG_NAME:=tor
|
||||||
PKG_VERSION:=0.2.5.10
|
PKG_VERSION:=0.2.5.12
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://www.torproject.org/dist \
|
PKG_SOURCE_URL:=https://www.torproject.org/dist \
|
||||||
https://archive.torproject.org/tor-package-archive
|
https://archive.torproject.org/tor-package-archive
|
||||||
PKG_MD5SUM:=4bde375229a7a7f77c0596ae05556527
|
PKG_MD5SUM:=89745069a7efb7aafd01ae263bd0fe5c
|
||||||
PKG_MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
|
PKG_MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
|
||||||
PKG_LICENSE_FILES:=LICENSE
|
PKG_LICENSE_FILES:=LICENSE
|
||||||
|
|
||||||
|
@ -82,7 +82,8 @@ CONFIGURE_ARGS += \
|
||||||
--with-libminiupnpc-dir="$(STAGING_DIR)/usr" \
|
--with-libminiupnpc-dir="$(STAGING_DIR)/usr" \
|
||||||
--enable-nat-pmp \
|
--enable-nat-pmp \
|
||||||
--with-libnatpmp-dir="$(STAGING_DIR)/usr" \
|
--with-libnatpmp-dir="$(STAGING_DIR)/usr" \
|
||||||
--disable-asciidoc
|
--disable-asciidoc \
|
||||||
|
--disable-seccomp
|
||||||
|
|
||||||
ifneq ($(CONFIG_SSP_SUPPORT),y)
|
ifneq ($(CONFIG_SSP_SUPPORT),y)
|
||||||
CONFIGURE_ARGS += \
|
CONFIGURE_ARGS += \
|
||||||
|
|
|
@ -14,7 +14,7 @@
|
||||||
|
|
||||||
## The port on which Tor will listen for local connections from Tor
|
## The port on which Tor will listen for local connections from Tor
|
||||||
## controller applications, as documented in control-spec.txt.
|
## controller applications, as documented in control-spec.txt.
|
||||||
@@ -187,3 +187,4 @@
|
@@ -190,3 +190,4 @@
|
||||||
## address manually to your friends, uncomment this line:
|
## address manually to your friends, uncomment this line:
|
||||||
#PublishServerDescriptor 0
|
#PublishServerDescriptor 0
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue